It's all about the answers!

Ask a question

During changeset delivery teamconcert client 4.0.0.2 Ubuntu fails with no more handles


David Ward (8311214) | asked Jun 23 '14, 9:10 a.m.
Running RTC client 4.0.0.2 on Ubuntu 14.04 x86-64.

(can't run a later client because my server is @ 4.0.0.2)

RTC functions just fine until I try to deliver a changeset.  When I do, I see the error shown below.

I've tried the shipped RTC client for eclipse and I've also tried adding RTC 4.0.0.2 to Eclipse Indigo and Helios.  In no case can I deliver anything successfully.

Any help appreciated

cheers
Dave





Comments
sam detweiler commented Jun 23 '14, 9:24 a.m. | edited Jun 23 '14, 9:25 a.m.

rtc requires you to increase the number of handles configuration on *IX.
I had to on 12.04

https://jazz.net/help-dev/clm/index.jsp?re=1&topic=/com.ibm.jazz.install.doc/topics/c_special_considerations_linux.html&scope=null


David Ward commented Jun 23 '14, 10:19 a.m. | edited Jun 23 '14, 11:58 a.m.

Thank you for that advice.  I did make the limits.conf update as described, rebooted, but the failure still occurs :-(



sam detweiler commented Jun 23 '14, 10:24 a.m. | edited Jun 23 '14, 10:29 a.m.

what does ulimit -n show for your logged on userid?

also I have seen problems reported that are solved by updating xulrunner

3 answers



permanent link
Alex Fitzpatrick (5583816) | answered Jun 23 '14, 4:09 p.m.
JAZZ DEVELOPER
edited Jun 23 '14, 5:51 p.m.
 I think your issue is with xulrunner on Ubuntu 14.04 x86-64.

I will verify on a virtual machine and update this answer with steps.

--

Update 1: As I suspected, having followed your steps from your related question, and launched eclipse the browser widget is clearly non-functional. The issue you have is most likely with xulrunner and/or webkit.

--

Update 2: xulrunner is not available in 14.04 in either 32 or 64 bit versions, looking for a way to make this work.

permanent link
David Ward (8311214) | answered Jun 23 '14, 4:20 p.m.
I tried 12.04 as well; same result.

ulimit reports ...

$ ulimit -n
65536



Comments
David Ward commented Jun 23 '14, 4:25 p.m.

Forgot to mention...

neither 12.04 nor 14.04 come with 32-bit library support out-of-the-box

For 12.04 I just installed ia32-libs.

For 14.04 I had to add i386 as an architecture, then do apt-get update following by an install ia32-libs.





Alex Fitzpatrick commented Jun 23 '14, 5:00 p.m.
JAZZ DEVELOPER

 Why not try the 64 bit RTC?


David Ward commented Jun 23 '14, 5:23 p.m.

I only see a 32 bit download for the RTC client (plain zip) for Linux. 

I have also tried installed RTC 4.0.0.2 into an existing 64-bit Eclipse Indigo and have seen similar problems with handles.


permanent link
Krzysztof Kaźmierczyk (7.5k478103) | answered Jun 24 '14, 3:36 p.m.
Hi all,
Please try work around from following article: https://jazz.net/library/article/952

Comments
Alex Fitzpatrick commented Jun 24 '14, 11:08 p.m.
JAZZ DEVELOPER

 Unfortunately, none of the packages suggested as workarounds exist in Ubuntu 14.04


David Ward commented Jun 24 '14, 11:27 p.m.

There seems to be more than one workaround in that article.  I picked one of them and installed Eclipse Juno 4.2 64-bit and set -Dorg.eclipse.swt.browser.UseWebKitGTK=true in the eclipse.ini (not sure if that was necessary).  A webkit+ was installed with the OS.    ulimit -n reports 65536.

I still saw "no more handles" errors while trying to deliver.

For me, the only combination that allows me to deliver is installing the RTC 4.0.0.2 client on an old Ubuntu 10.04 32-bit system. That did work but, so far, no 64-bit Ubuntu has worked.


David Ward commented Jun 30 '14, 5:14 p.m.

Kind of stuck here.

Should I open a defect ?
or perhaps TeamConcert client isn't supported on Ubuntu 64-bit ?

Your answer


Register or to post your answer.


Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.