It's all about the answers!

Ask a question

Errors occurred while the comma-separated values (CSV) file was being imported to the RRC 4.0.3


long TRUONG (3654117146) | asked May 29 '14, 6:34 p.m.
 Can't figure out what's wrong with the import or the data in the import file. Note that the same CSV file has been imported successfully to the IBM sandbox 2.

Wonder if that has anything to do with importing requirements from a project on PROD, into a project on DEV , where the same access URI is used by tying the URL with the Dev server IP in the hosts file.

Errors occurred while the comma-separated values (CSV) file was being imported.
hide details
ID CRRRW7571E  The errors might be due to problems with the file content. Review the status messages shown. You may be able to modify the .csv file or modify the type system to allow the file to be imported without errors.
Errors were received while importing the CSV file: 

Validation Errors: 
Row Number: 1
Error Message: Propagated exception; original message [CRRRS8657E An invalid value was specified for the attribute definition URL https://rtc-web1.ent.rt.csaa.com/rm/types/_pJWjsGNxEeGQKPQbsGRGlw#e8807f3e-e6c0-46b5-899e-638ff43a811f. ] 
Row Number: 2
Error Message: Propagated exception; original message [CRRRS8657E An invalid value was specified for the attribute definition URL https://rtc-web1.ent.rt.csaa.com/rm/types/_pJWjsGNxEeGQKPQbsGRGlw#e8807f3e-e6c0-46b5-899e-638ff43a811f. ] 
Row Number: 3
...
...
for all of 20 rows

Comments
long TRUONG commented May 29 '14, 7:03 p.m.

Definitely it's the URL spoofing which caused issue: I exported  requirements from a DEV project then reimported it back in under a different folder with name changes, got exactly same errors.


Anybody has an idea or an explanation ?

3 answers



permanent link
long TRUONG (3654117146) | answered Jul 21 '14, 7:05 p.m.
 This can't be marked as the right answer, as it is my own: However it is the right answer.

Sumitted [PMR 19291,49R,000], which is still opened:
  • Only import (even from export of the very same PA) of a specific artifact type SysReq not working.
  • If imported as any other type would be OK: then the type can be modified after import.
  • The issue is traced to a particular attribute PolTyp
  • It is using an enumeration, and an initial value is required for the import to be successful, even though no PolTyp value is on the CSV file for import.
  • Setting the initial value for PolTyp is the workaround to get the import to work with SysReq type.
  • Oddly enough, if there had been no description for PolTyp, then the initial value is not required; i.e. removing the description from PolTyp (while leaving it without an initial value) is also an effective workaround.
  • Moral: An attribute by enumeration, with description, will need to have an initial value; if no initial value is to be assigned there should be no description for the import of that type to work. Have not yet tried one with initial value without a description.
That was what we found from IBM suggestions of a workaround, the PMR is still open, will update with any more to come.

permanent link
Donald Nong (14.5k414) | answered May 29 '14, 8:28 p.m.
By the look of it, the URL in the error message refers to an enumeration value. Is the URL the raw data in the CSV file? if so, it is not going to work on another system since the type system will be completely different. I would expect the literal value of the enumeration to appear in the CSV file.

Comments
long TRUONG commented May 29 '14, 9:23 p.m.

THat was what I thought, however there are no links on the requirements hence no link exported to the CSV file: Id, Name, Artifact Type, Last mod by, Last mod date








long TRUONG commented May 29 '14, 9:25 p.m.

 Besides the exact same CSV file got imported to the RRC on IBM sandbox 2 without a hitch.


Donald Nong commented May 29 '14, 11:30 p.m.

On second though, I think you might have a more serious problem with the system in question - the type system may be corrupted.
Follow the instructions in this article to get the type system feed - removing " &refreshTypeFeedCacheFromJFS=true " from the end of the URL will give you the type system feed rather than refresh it.
https://jazz.net/library/content/articles/rrc/4.0/workaround-migration-unresponsive-script/
Once you get it, check if you can find the entry which gets complained in the error message.


permanent link
Richard Good (872157) | answered Apr 10 '18, 10:54 a.m.

Thanks Long, that horrible error message has cost me a few hours. Specifying defaults on multi enumerates not in the csv I'm tring to import solved it.

Why can't it say something like, a default needs to be set for attribute type, not some gobbledygook?

Your answer


Register or to post your answer.