It's all about the answers!

Ask a question

\build\Classes not found


Ahmad Husain Mohamed (612) | asked Mar 06 '14, 2:38 a.m.
edited Mar 06 '14, 7:55 a.m. by Krzysztof Ka┼║mierczyk (7.3k34391)
Hi I am new and I am trying to build using the Jazz Build (Ant) I have specified the properties, load directories and also the build file.

But every time I submit a request I get the below error.

Can anyone help me resolve this please?

Thanks

2014-03-06 11:10:59 [Jazz build engine] 2014-03-06 11:10:59 [Jazz build engine] Substituted the following build property variables: 2014-03-06 11:10:59 [Jazz build engine] team.scm.fetchDestination = ${outputRootDirectory}\${buildLabel} --> team.scm.fetchDestination = testbuild\C20140306-1110 2014-03-06 11:10:59 [Jazz build engine] 2014-03-06 11:10:59 [Jazz build engine] 2014-03-06 11:10:59 [Jazz build engine] Substituted the following configuration element property variables: 2014-03-06 11:10:59 [Jazz build engine] com.ibm.team.build.ant : com.ibm.team.build.ant.buildFile = ${outputRootDirectory}\${buildLabel}\NGeP-biz-fl\build\build.xml --> com.ibm.team.build.ant.buildFile = ${outputRootDirectory}\C20140306-1110\NGeP-biz-fl\build\build.xml 2014-03-06 11:10:59 [Jazz build engine] com.ibm.team.build.ant : com.ibm.team.build.ant.buildFile = ${outputRootDirectory}\C20140306-1110\NGeP-biz-fl\build\build.xml --> com.ibm.team.build.ant.buildFile = testbuild\C20140306-1110\NGeP-biz-fl\build\build.xml 2014-03-06 11:10:59 [Jazz build engine] 2014-03-06 11:10:59 [Jazz build engine] running on host: NGEPTestJTSS01 2014-03-06 11:10:59 [Jazz build engine] Should build occur? 2014-03-06 11:10:59 [Jazz build engine] Yes: Always build a user initiated request. 2014-03-06 11:10:59 [Jazz build engine] Invoking pre-build participant "com.ibm.team.build.jazzscm" 2014-03-06 11:10:59 [Jazz build engine] Accepting changes into workspace "Fullfillment Sample Workspace" ... 2014-03-06 11:10:59 [Jazz build engine] Deleting fetch destination "/opt/IBM/jazz/buildsystem/buildengine/eclipse/testbuild/C20140306-1110" before fetching ... 2014-03-06 11:10:59 [Jazz build engine] Fetching files to fetch destination "/opt/IBM/jazz/buildsystem/buildengine/eclipse/testbuild/C20140306-1110" ... 2014-03-06 11:11:01 [Jazz build engine] Invoking build participant "com.ibm.team.build.ant" Buildfile: /opt/IBM/jazz/buildsystem/buildengine/eclipse/testbuild/C20140306-1110/NGeP- biz-fl/build/build.xml run: BUILD FAILED /opt/IBM/jazz/buildsystem/buildengine/eclipse/testbuild/C20140306-1110/NGeP- biz-fl/build/build.xml:9: /opt/IBM/jazz/buildsystem/buildengine/eclipse/testbuild/C20140306-1110/NGeP- biz-fl/build/classes not found. Total time: 0 seconds Build failed. Exit value was 1.

Comments
Krzysztof Ka┼║mierczyk commented Mar 06 '14, 7:55 a.m.

Hi Ahmad
You build failed on 9th line of build.xml. Please look at that line and check what could go wrong there. You can try pasting it to the chat here.

Be the first one to answer this question!


Register or to post your answer.