It's all about the answers!

Ask a question

Can you put a Plan View widget from 4.0.3 on a 4.0.2 dashboard between "friended" projects?


Michael Walker (99213193157) | asked Mar 06 '14, 2:08 a.m.
We have a customer on CLM 4.0.2.  They are "friends" with 2 other repositories that are on CLM 4.0.1 and CLM 4.0.3.   We're trying to add widgets from those "friends" onto the CLM 4.0.2's RQM dashboard.  Most widgets work fine, but when we add the Plan View widget from the CLM 4.0.3 RTC project onto the CLM 4.0.2 RQM project dashboard, it's stuck on Loading....   forever.  The title of the widget populates with the link to the plan correctly and if we click on the title it takes us to the correct Plan in the RTC project. But it will never display on the dashboard. So at least the linking is working, just not the display.  I've also tried all the plan view types.  Other widgets that are not plans work fine.

When we try putting the Plan View widget from the CLM 4.0.1 RTC Project onto the CLM 4.0.2 RQM Project dashboard everything works fine.

Is there a limitation with placing Plan widgets on a downlevel dashboard (4.0.3 plan on 4.0.2 dashboard)?  I looked in the application logs and couldn't find any errors.

Comments
Michael Walker commented Mar 06 '14, 1:37 p.m.

bump bump bump

Accepted answer


permanent link
Vladimir Zahariev (1503) | answered Mar 06 '14, 4:48 p.m.
JAZZ DEVELOPER
In that case I agree, this does appear to be a different problem. Please open a defect to track it.
Michael Walker selected this answer as the correct answer

Comments
Michael Walker commented Mar 06 '14, 5:39 p.m.

Thanks...I opened Defect 107750 against RQM with Filed Against = Dashboard & Viewlets.

https://jazz.net/jazz02/web/projects/Rational%20Quality%20Manager#action=com.ibm.team.workitem.viewWorkItem&id=107750


James Palmer commented Jun 24 '14, 12:27 p.m.

So, I ran into a similar issue, but not with "friended" projects.  The problem I had was with 4.0.3 itself.  It appears to be a bug with 4.0.3 and the "Plan View" widget.  4.0.1 works fine, and, based on the comments in the defect called out above, 4.0.6 works fine (I haven't confirmed this as I don't have that version).  4.0.5 has a very odd issue with the Plan View widget.  I tried displaying the Taskboard using this widget and it showed the taskboard, but the boxes representing the tasks were empty... hopefully 4.0.6 and beyond fix this issue.

One other answer



permanent link
Vladimir Zahariev (1503) | answered Mar 06 '14, 2:11 p.m.
JAZZ DEVELOPER

Comments
Michael Walker commented Mar 06 '14, 2:29 p.m.

Vladimir,

Thank you for the response.  It doesn't seem to match my problem.  I'm not doing any resizing or changing settings.  I'm just adding the widget. It works fine when I add the Plan View widget from a 4.0.1 repository but just gets stuck on Loading when adding from a 4.0.3 repository.   If it was the above problem I'd think it would fail for both repositories.

Your answer


Register or to post your answer.