It's all about the answers!

Ask a question

Many PNG files in /tmp directory on RTC server


Kot T. (1.5k11219) | asked Mar 04 '14, 7:28 p.m.
JAZZ DEVELOPER
edited Mar 04 '14, 7:48 p.m.
Observe many png files in the /tmp directory on their CCM server. These png files are about 11 KB in size and the file name starts with 'sprite'.




When opening many of these files, they show many icons that we would normally see in CLM. For example,

 

QUESTIONS:
1. What are these png files used for?
2. Is there a way to limit the number of these files created in the /tmp directory?
3. Is it possible to configure some scheduled tasks in CCM to clean up these files?

Accepted answer


permanent link
Kot T. (1.5k11219) | answered Mar 05 '14, 9:57 a.m.
JAZZ DEVELOPER
Millard Ellingsworth selected this answer as the correct answer

Comments
Millard Ellingsworth commented Mar 05 '14, 11:06 a.m.
FORUM ADMINISTRATOR / JAZZ DEVELOPER

As I understand it (thanks @nl84936) this was introduced with RTC 4.0.5 and users may also see an error similar to this in the ccm.log:


2014-02-26 14:13:50,823 [http-bio-9443-exec-167 @@ 14:13 jazzadmin /ccm/service/
com.ibm.team.rtc.common.internal.service.web.sprite.ISpriteImageService/js/bundle] ERROR com.ibm.team.rtc.common.service                     - Problems
serving sprite image service request
com.ibm.team.repository.common.TeamRepositoryException: Unknown bundle id: bundleentry/522


Mallikarjuna Kandala commented Apr 07 '14, 7:50 a.m.

Hi,

Thanks for your post.

We recently apllied ( Hotfix_290636 and Hotfix_303501 for CLM 4.0.5 ) and after that none of the WI Queries are working.

I'm seeing similar errors in logs as mentioned by you above.

What could be the reason for this ?

can you please suggest.


Kot T. commented Apr 07 '14, 12:56 p.m.
JAZZ DEVELOPER

Hi Mallikarjuna,

See defect sprite files accumulating in /tmp (286513) for more details about the sprite image service error.

I do not think the sprite image service error is related to the WI query issue you are seeing. What do you mean by not working? Do you get any error messages when running the queries? OR the queries run, but do not return any results (or return unexpected results)? I would like to suggest the following actions:

1. If the queries run, but return unexpected results, please run repotools -reindex and -rebuildTextIndices on both JTS and CCM. Ensure that the commands run successfully.

2. Submit a PMR to engage Support.


Liora Milbaum commented May 14 '14, 7:22 a.m.

Where can we find the Hotfixes (Hotfix_290636 and Hotfix_303501)?


Krzysztof Kaźmierczyk commented May 14 '14, 8:20 a.m.

Hi Liora,
Please create new PMR request for these hotfixes if you need them.


Kot T. commented May 14 '14, 8:22 a.m.
JAZZ DEVELOPER

Hi Liora,

You can submit a PMR with Support to request for the hotfix. Please include the following information in the PMR:

- Version and environment information of the CLM server where the hotfix will be applied (eg. WAS/Tomcat, Operating Server, DB vendor and version, etc.)
- List of existing hotfixes, if there are already some other hotfixes installed on the server
- Business Impact/Justification to why the hotfix is needed.


Liora Milbaum commented May 14 '14, 8:24 a.m.

Thanks. I will. 

showing 5 of 7 show 2 more comments

Your answer


Register or to post your answer.