It's all about the answers!

Ask a question

What to do with "Problem running 'create workspace'" error message with CLI tool

alex ben (312) | asked Feb 06 '14, 4:27 p.m.
edited Feb 06 '14, 4:33 p.m.
 Hello, I'm having an issue when trying to create a workspace using the CLI tool.  The following message is showed:

Ambiguous selector "Maintenance - Config" matched multiple items:
Possible matches:
  (1004) "Maintenance - Config"
  (1005) "Maintenance - Config"
Problem running 'create workspace':
Ambiguous stream selector "Maintenance - Config"

The command I'm using is this one:
--> scmtools/eclipse/lscm create workspace -r https://rtcsvr01:9443/jazz -u <user> -P <myPassword> -s "Maintenance – Config" "Maintenance – Config – <user>”

I already contacted the administrator but she was unable to locate a duplicate stream with that name in the RTC Server.  Do you know what can be wrong, or what steps can I do to fix this ?

By the way, this is the only stream that is giving me the error, I already tried with other 57 streams and no one gave me any error.

The client version is:, version 3.0.3.v20120308_1209

Accepted answer

permanent link
Lily Wang (4.9k714) | answered Feb 06 '14, 7:20 p.m.
Hi Alex,

If you know which stream you want to use, you can use the 4 digit alias shown in brackets in your commands instead of the stream name.
For example: lscm create workspace -r https://rtcsvr01:9443/jazz -u <user> -P <mypassword> -s 1004 "Maintenance – Config – <user>”
Note: the aliases cannot be used across systems or it should not be used in scripts.

You can also run "lscm list stream -v" to list all streams in the repository.
alex ben selected this answer as the correct answer

alex ben commented Feb 07 '14, 10:08 a.m.

Thanks a lot Lily, I have tried to create it with the 4 digits alias and that helped me a lot, because I found that the main issue was related that another User created another stream with the same name, so that caused the problem.

I just asked the user to delete that stream and now everything is working fine.

By the way, when you run the "lscm list stream -v" there is a parameter you can use called "--maximum", that is useful when you have more than 10 streams on your repository (like my case).

Your answer

Register or to post your answer.