Why is Websphere failing to install WAR file that was initially installed on Tomcat but installs same WAR file when initially installed for Websphere?
We plan on migrating our CLM repositories from Tomcat to Websphere. We setup a test CLM project (JTS/RTC 4.0.3) on Tomcat on a Windows 2008 server with DB2 on the backend. We then followed the instructions in the CLM Help for migrating from Tomcat to Websphere.
We installed Websphere ND 8.0.0.8 and setup the initial Deployment Manager and Profiles. We ran the first jython script to set the parameters, JAZZ_HOME, etc. in the WAS profile. We then ran the 2nd jython command to install the WAR files. We pointed to the WAR files in the Tomcat directory from the initial install.
It fails on the error below. To verify we setup WAS correctly I ran the same jython command against a directory that has WAR files from a CLM installed with the Tomcat box unchecked. That jts.war file installed successfully. So there seems to be an issue with the war files that were created to work with Tomcat.
Is this a known issue and is there a step we're missing that I'm not seeing in the help? Some searching brought up a post that said the issue is with the deployment descriptors and Tomcat didn't verify them where WAS does. I verified the web.xml file exists in the WEB-INF dir.
Installing jts
Error Installing Application
Error Message = com.ibm.ws.scripting.ScriptingException: com.ibm.websphere.manag
ement.application.client.AppDeploymentException: com.ibm.websphere.management.ap
plication.client.AppDeploymentException: [Root exception is org.eclipse.jst.j2e
e.commonarchivecore.internal.exception.DeploymentDescriptorLoadException: WEB-IN
F/web.xml]
org.eclipse.jst.j2ee.commonarchivecore.internal.exception.DeploymentDescriptorLo
adException: org.eclipse.jst.j2ee.commonarchivecore.internal.exception.Deploymen
tDescriptorLoadException: WEB-INF/web.xml
We installed Websphere ND 8.0.0.8 and setup the initial Deployment Manager and Profiles. We ran the first jython script to set the parameters, JAZZ_HOME, etc. in the WAS profile. We then ran the 2nd jython command to install the WAR files. We pointed to the WAR files in the Tomcat directory from the initial install.
It fails on the error below. To verify we setup WAS correctly I ran the same jython command against a directory that has WAR files from a CLM installed with the Tomcat box unchecked. That jts.war file installed successfully. So there seems to be an issue with the war files that were created to work with Tomcat.
Is this a known issue and is there a step we're missing that I'm not seeing in the help? Some searching brought up a post that said the issue is with the deployment descriptors and Tomcat didn't verify them where WAS does. I verified the web.xml file exists in the WEB-INF dir.
Installing jts
Error Installing Application
Error Message = com.ibm.ws.scripting.ScriptingException: com.ibm.websphere.manag
ement.application.client.AppDeploymentException: com.ibm.websphere.management.ap
plication.client.AppDeploymentException: [Root exception is org.eclipse.jst.j2e
e.commonarchivecore.internal.exception.DeploymentDescriptorLoadException: WEB-IN
F/web.xml]
org.eclipse.jst.j2ee.commonarchivecore.internal.exception.DeploymentDescriptorLo
adException: org.eclipse.jst.j2ee.commonarchivecore.internal.exception.Deploymen
tDescriptorLoadException: WEB-INF/web.xml
2 answers
HI Michael,
Could you try the manual migration steps and see where its failing. can you follow the below link and see does it helps.
http://pic.dhe.ibm.com/infocenter/clmhelp/v4r0m1/index.jsp?topic=%2Fcom.ibm.jazz.install.doc%2Ftopics%2Ft_migrate_tomcat_was.html
Regards,
Arun.
Could you try the manual migration steps and see where its failing. can you follow the below link and see does it helps.
http://pic.dhe.ibm.com/infocenter/clmhelp/v4r0m1/index.jsp?topic=%2Fcom.ibm.jazz.install.doc%2Ftopics%2Ft_migrate_tomcat_was.html
Regards,
Arun.
The problem is that the WAR file prepared for Tomcat deployment has customized web.xml file. It includes security group mapping to LDAP groups, and it cannot be deployed on WAS. You should have the original file backup in the same directory, or you can use one from another "fresh" installation.
Comments
Michael Walker
Feb 05 '14, 11:37 a.m.Donald Nong
Feb 06 '14, 12:44 a.m.Michael Walker
Feb 06 '14, 2:46 a.m.Donald Nong
Feb 07 '14, 12:09 a.m.Michael Walker
Feb 07 '14, 1:25 a.m.Indradri Basu
Feb 07 '14, 6:08 a.m.Karl Weinert
JAZZ DEVELOPER Feb 07 '14, 9:52 a.m.Michael Walker
Feb 09 '14, 11:59 p.m.Donald Nong
Feb 10 '14, 1:21 a.m.Michael Walker
Feb 14 '14, 5:09 p.m.