It's all about the answers!

Ask a question

Why is Websphere failing to install WAR file that was initially installed on Tomcat but installs same WAR file when initially installed for Websphere?


Michael Walker (99214198157) | asked Feb 05 '14, 2:32 a.m.
We plan on migrating our CLM repositories from Tomcat to Websphere.  We setup a test CLM project (JTS/RTC 4.0.3) on Tomcat on a Windows 2008 server with DB2 on the backend.  We then followed the instructions in the CLM Help for migrating from Tomcat to Websphere.

We installed Websphere ND 8.0.0.8 and setup the initial Deployment Manager and Profiles.  We ran the first jython script to set the parameters, JAZZ_HOME, etc. in the WAS profile.  We then ran the 2nd jython command to install the WAR files.  We pointed to the WAR files in the Tomcat directory from the initial install.

It fails on the error below.  To verify we setup WAS correctly I ran the same jython command against a directory that has WAR files from a CLM installed with the Tomcat box unchecked.  That jts.war file installed successfully. So there seems to be an issue with the war files that were created to work with Tomcat.

Is this a known issue and is there a step we're missing that I'm not seeing in the help?  Some searching brought up a post that said the issue is with the deployment descriptors and Tomcat didn't verify them where WAS does.  I verified the web.xml file exists in the WEB-INF dir.

Installing jts
Error Installing Application
Error Message = com.ibm.ws.scripting.ScriptingException: com.ibm.websphere.manag
ement.application.client.AppDeploymentException: com.ibm.websphere.management.ap
plication.client.AppDeploymentException:  [Root exception is org.eclipse.jst.j2e
e.commonarchivecore.internal.exception.DeploymentDescriptorLoadException: WEB-IN
F/web.xml]
org.eclipse.jst.j2ee.commonarchivecore.internal.exception.DeploymentDescriptorLo
adException: org.eclipse.jst.j2ee.commonarchivecore.internal.exception.Deploymen
tDescriptorLoadException: WEB-INF/web.xml

Comments
Michael Walker commented Feb 05 '14, 11:37 a.m.

bump bump bump 


Donald Nong commented Feb 06 '14, 12:33 a.m. | edited Feb 06 '14, 12:44 a.m.

The .war files that you got from different installation methods should be the same. The only possibility that I can think of is the .war files are locked by Tomcat when it is running. Have you tried the script by stopping Tomcat first?
Other than that, you can also try to install the .war file in the WAS admin console.
http://pic.dhe.ibm.com/infocenter/clmhelp/v4r0m3/topic/com.ibm.jazz.install.doc/topics/t_deploy_was.html


Michael Walker commented Feb 06 '14, 2:46 a.m.

I stopped the java process related to the Tomcat instance of RTC and failed at accessing the project to verify it's down.  I then tried installing the war files manually.  Both JTS.war and CCM.war failed on the similar error below as through the jython scripts.  The Admin.war and CLMHelp.war files both installed fine.

The following exception occurred. Check log for details.
com.ibm.websphere.management.application.client.AppDeploymentException: [Root exception is org.eclipse.jst.j2ee.commonarchivecore.internal.exception.DeploymentDescriptorLoadException: WEB-INF/web.xml]


Donald Nong commented Feb 07 '14, 12:09 a.m.

Without the complete log files, it's hard to say what went wrong. Since you could install the jts.war that you got from a different installation, have you compared whether the working jts.war is indeed the same as the failing one?


Michael Walker commented Feb 07 '14, 1:25 a.m.

Interesting...We have 2 installs on this system, one is 4.0.1 and the other is 4.0.3. The WAR file in the 4.0.3 install is the one failing. The WAR file in 4.0.1 works fine.  I'll compare them when I get a chance.

Which logs should I look in to find errors when failures occur during install of war file?  I looked at a couple in WAS but couldn't find an error.

Do the WAR files have any install-specific information in them or are they interchangeable?  For example, if I migrate an install from Tomcat to Websphere, do we have to use the war files that were installed with Tomcat or can they come from any install?


Indradri Basu commented Feb 07 '14, 6:08 a.m.

WebSphere profile's SystemOut.log should give information about errors however you mentioned you have created deployment manager node. Wondering if you are trying to replicate a distributed deployment scenario ? Generally just an "application server" profile in WAS would solve the purpose and you don't need a DMGR unless your deployment is across multiple servers. Secondly, I would probably install CLM in a new folder and keep the original as a backup till my switch from tomcat to WAS is over so that the running setup is not disturbed. Then later on it can be cleaned up as needed.


Karl Weinert commented Feb 07 '14, 9:52 a.m.
JAZZ DEVELOPER

Which py file are you running?
It could just be a corrupted war file.
I found a couple links that might be helpful
http://www-01.ibm.com/support/docview.wss?uid=swg21177714
https://www.ibm.com/developerworks/community/forums/html/topic?id=77777777-0000-0000-0000-000000035358


Michael Walker commented Feb 09 '14, 11:59 p.m.

Found the error farther below in the systemErr.log. Looking it up says there's duplicate nodes in the web.xml  but I couldn't find any.

We're working with WASND because we support over 30 different CLM repositories and plan on moving them all from Tomcat to Websphere. 

Is it true you can use a war file from another installation.....i'm assuming as long as it's the same 4.0.x version? 

Someone recommended a separate CLM install for moving to WAS and moving everything over.  This is different than what the CLM Help says. Which is recommended? 

thanks,





[2/5/14 23:30:19:939 PST] 00000020 SystemErr     R Caused by: org.eclipse.jst.j2ee.commonarchivecore.internal.exception.DeploymentDescriptorLoadException: WEB-INF/web.xml
.
.
.
.
.
[2/5/14 23:30:20:001 PST] 00000020 SystemErr     R Caused by: java.lang.IllegalStateException: EMF2DOMAdapterImpl_ERROR_0


Donald Nong commented Feb 10 '14, 1:21 a.m.

There is only one copy of the .war file in the installation source. It will only be extracted from another compressed file, but not modified in any way. Regardless it is copied to tomcat/webapps/ or not, it should be the same file.


Michael Walker commented Feb 14 '14, 5:09 p.m.

bump bump bump

showing 5 of 10 show 5 more comments

2 answers



permanent link
Arun K Sriramaiah (3.2k12254) | answered Feb 05 '14, 12:48 p.m.
HI Michael,

Could you try the manual migration steps and see where its failing. can you follow the below link and see does it helps.

http://pic.dhe.ibm.com/infocenter/clmhelp/v4r0m1/index.jsp?topic=%2Fcom.ibm.jazz.install.doc%2Ftopics%2Ft_migrate_tomcat_was.html

Regards,
Arun.

Comments
Michael Walker commented Feb 10 '14, 12:00 a.m.

manual failed on same step..only worked when I grabbed WAR file from another install...or at least I got past that step.


permanent link
Pavel Dubovitsky (2814) | answered Feb 10 '14, 4:17 p.m.
The problem is that the WAR file prepared for Tomcat deployment has customized web.xml file. It includes security group mapping to LDAP groups, and it cannot be deployed on WAS. You should have the original file backup in the same directory, or you can use one from another "fresh" installation.

Comments
Donald Nong commented Feb 10 '14, 7:23 p.m.

Can you please clarify from which source you get this information? It's complete the opposite to what I understand. In fact, you can extract these .war file from the installation media without installing.

admin.war        com.ibm.team.lpa.war_###.zip
ccm.war            com.ibm.team.install.jfs.app.rtc.war_###.zip (as rtc.war in the archive)
clmhelp.war        com.ibm.clm.help.war_###.zip
converter.war    com.ibm.rdm.converter.war.<platform>###.zip
jts.war            com.ibm.team.install.jfs.app.jazz.war
###.zip (as jazz.war in the archive)
qm.war            com.ibm.team.install.jfs.app.rqm.war_###.zip
rm.war            rdmWar_###.zip

The .zip files can be found in the "native" folder in the installation media and ### stands for the version_build number which varies between versions.

I can confirm that the .war files are identical in both deployment.


Pavel Dubovitsky commented Feb 10 '14, 7:39 p.m.

I had the same issue, and I compared original war files with the files that were prepared for Tomcat deployment. Tomcat's ccm.war, jts.war, and qm.war contained customized WEB-INF/web.xml with security roles mapped to the actual LDAP groups. 
Obviously, the freshly extracted extracted files did not have these customizations, and I was able to install them on a WebSphere with no issue.

Your answer


Register or to post your answer.