It's all about the answers!

Ask a question

Do I realy have to upgrade RRDI 203 before CLM 403?


Guido Schneider (3.3k137699) | asked Jun 10 '13, 9:01 a.m.
retagged Jun 10 '13, 12:02 p.m. by Francesco Chiossi (5.7k1719)

I'm running currently CLM 402 with RRDI 201.

I started now the upgrade to CLM403 and have read that we should first upgrade RRDI 203.

https://jazz.net/downloads/rational-team-concert/releases/4.0.3?p=upgrading

"You must upgrade Rational Reporting for Development Intelligence before you upgrade your server applications"

Is this true? Why?

(I'm talking from UPGRADE not from NEW INSTALLATION)


Comments
Ralph Schoon commented Jun 10 '13, 11:36 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

Hi Guido, in the past it was necessary to upgrade RRDI and Insight to allow the DW to handle changed ETL jobs etc. I assume this is the case here too. Although I don't know if there are changes between 4.0.2 and 4.0.3 that would make this necessary.

Accepted answer


permanent link
Rosa Naranjo (2.8k11420) | answered Jun 13 '13, 5:07 p.m.
FORUM MODERATOR / JAZZ DEVELOPER
Guido
Please read the latest update to the recommendations on upgrade order when reporting is involved:
https://jazz.net/wiki/bin/view/Deployment/UpgradePlanning#Reporting_considerations

In the past we have been recommeding that RRDI or Insight be upgraded first, but we have learned from field experience that it is smoother if you upgrade CLM first then proceed with RRDI or Insight.  For RRDI, I have noted this workitem in the topic above:  https://jazz.net/jazz/web/projects/Jazz%20Collaborative%20ALM#action=com.ibm.team.workitem.viewWorkItem&id=266234
Guido Schneider selected this answer as the correct answer

3 other answers



permanent link
Francesco Chiossi (5.7k1719) | answered Jun 10 '13, 12:01 p.m.
Hello Guido,

my interpretation is that this would cover a staged upgrade scenario, for example If you want to maintain the reporting capabilities available to the users while migrating one component at time.
RRDI 2.0.3 should work against a CLM 4.0.2 installation.

I think the ideal scenario would be to upgrade both atomically, in that case I don't think the order would be very important.

Best Regards
Francesco

permanent link
Ralph Schoon (55.5k23642) | answered Jun 11 '13, 10:28 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
I attended a talk today and the conclusion is that RRDI etc. need to be at the right level compared to JTS. So you have to upgrade RRDI, RRDG, Insight before you upgrade JTS.

-1
permanent link
Piotr Aniola (3.6k1534) | answered Jun 12 '13, 4:51 a.m.
edited Jun 12 '13, 6:43 a.m.
Perhaps the answer is trivial, the supported version of RRDI has been *tested* against CLM 4.0.3 and is known to work. The older version might or might not work.
Please note, that significant effort would have to be put into SVT testing, if we wanted to test all old versions of RRDI against each version of CLM, so instead, a useful subset is selected for tests (and therefore support).
I would strongly recommend to always use only supported versions of any software, doing otherwise will make it difficult to receive support in case something goes wrong.

Your answer


Register or to post your answer.