It's all about the answers!

Ask a question

Does formating (bold and italic) work in a Multi-Line HTML Default Value Attribute Customization?


Tim Fuller (471125) | asked Jan 09 '14, 5:17 p.m.
edited Jan 10 '14, 4:47 a.m. by Krzysztof Kaźmierczyk (7.4k34796)

Article 1002 on customization of work items says (Default Values section of article) you can use bold and italic when setting up a Multi-Line HTML Default Value.  Using 4.0.3 it doesn't seem to work.  Highlighting the text and pressing Cntl-b or -i has not effect.  HTML links and links to users (@xxxxx) and to work items (work item 387) do work. 

Am I missing something?


Comments
Tim Fuller commented Jan 09 '14, 5:19 p.m. | edited Jan 09 '14, 5:20 p.m.

-


Krzysztof Kaźmierczyk commented Jan 10 '14, 4:29 a.m. | edited Jan 10 '14, 10:42 a.m.

Hi Tim,
I have tried it in the latest version and it works correctly. Also I don't remember there were any issues with that.

Can you provide what is attribute presentation type you are using and what exactly work item attribute type you have set?


Tim Fuller commented Jan 10 '14, 10:29 a.m.

We're using 4.0.3.  I've tried medium and large-HTML as the attribute type, the presentation type is HTML. 

The screen cap below is from the attribute customization that I'm using as default for the attribute. It's in the Configuration field that I'm trying to use bold and italic but its not working.
AttributeCustomizationHTML

One answer



permanent link
Krzysztof Kaźmierczyk (7.4k34796) | answered Jan 10 '14, 10:57 a.m.
Hi Tim,
I tried it on my machine on 4.0.3 and it works correctly (ctrl+b bolds text). Can you try writing some formated text e.g. in Word or OpenOffice and paste it into the value?

Also please check <your-workspace>/.metadata/.log file wheteher there are any errors. It is also worth of checking on out of the box RTC client (https://jazz.net/downloads/rational-team-concert/releases/4.0.3/RTC-Client-Win-4.0.3.zip) with new workspace selected.

Let us know about the results.

Comments
Tim Fuller commented Jan 10 '14, 12:15 p.m.

I tried copying in text from Word. The bold text turned unbolded when copied into the field.

I did try it with an out of the box Eclipse Client for 4.0.3 as you suggested, and the bold text did work in the customization field and did display on the work item in the attribute. Success!  Thanks!

Having an Eclipse client malfunction is not something I would expect.  Is that common?


Krzysztof Kaźmierczyk commented Jan 10 '14, 1:14 p.m.

Definietely it should work also on your original Eclipse client. Anyway we were able to narrow down the issue.
If you still want to investigate why it originally did not work, please provide the output of your <your-workspace>/.metadata/.log file and let us know how you installed that client (what was original Eclipse version, whether it was pure Eclipse or another product and how you installed RTC plugin (using p2 installer or installation manager))

Your answer


Register or to post your answer.