It's all about the answers!

Ask a question

RFT with RTC eclipse plugin for use with RTC Source Control outofmemory errors


Brandy Guillory (5311925) | asked Nov 19 '13, 5:32 p.m.
edited Nov 19 '13, 9:54 p.m.
Hi ,

I am running RFT 8.0 with the RTC eclipse plugin for use with RTC Source Control and I was working fine, writing/running scripts & batch files and now I am encountering outofmemory maxheap errors on every script I run and when I attach to the jconsole to view the activity. It is maxed with the maxheap memory on javaw.exe.

Things I have tried:
1. I have tried using a new workspace as the jazz forums suggested a corrupt workspace. that did not work.
2. I tried increasing JVM maxheap and perm memory sizes xms,xmx to around 2047 because 2048 doesn't work. I set perm to 4096. This did not fix it.
3. I reinstalled java 7. This did not fix it
4. I uninstalled both RFT and RTC plugin, setup RTC source control again and still get the errors

Could this be a memory leak/garbage collection issue of some sort or should i wipe the VM and start installing these tools again?Any help would be appreciated


Comments
Millard Ellingsworth commented Nov 22 '13, 5:47 p.m.
FORUM ADMINISTRATOR / JAZZ DEVELOPER

So even the smallest, simplest script causes an error even on a fresh start?


When you say you increased the memory, did you do it via the eclipse.ini file?

Have you turned on the show heap status feature? http://stackoverflow.com/questions/2774896/eclipse-garbage-collector-button

Is it possible you changed something about the execution of the scripts at some point that is causing this? So that no matter how much memory you give it, it will find a way to use it all?

FTR, RFT is not supported via this forum, but we'll help if we can.


Brandy Guillory commented Dec 17 '13, 4:49 p.m.

thank you for your help. I actually figured it out via a coworker, it was a change that was checked in that RTC did not like, go figure.

Be the first one to answer this question!


Register or to post your answer.