It's all about the answers!

Ask a question

CRJAZ0215I The following record was not found in the database


Mike Shkolnik (9657149143) | asked Nov 05 '13, 2:27 p.m.
retagged Nov 05 '13, 3:51 p.m. by Laura W. Hinson (16126)
I have a work item that cannot be saved because it has a child that has been purged (deleted via the web UI). I try to remove the child link, but Save still fails because of the missing child, even though I have removed the link. How do I fix this? And why didn't deleting the child remove this link? RTC 4.0.1

Comments
Mike Shkolnik commented Nov 13 '13, 4:03 p.m.

This appears to be a major problem in 4.0.1. Deleting work items does not remove them from links of other work items.

2 answers



permanent link
Don Yang (7.1k2189124) | answered Nov 13 '13, 10:59 p.m.
Hi, Mike

We see similar report from other users in different version of RTC and it seems the issue is related to browser cache in some cases.
Can you please check:
if you open the parent in another browser the deleted child is still seen in the parent workitem or not? If not, clearly sthis issue is to do with the browser cache, a simple workaround to know the true state of the work item would be hit CTRL+F5 (clears the browser cache and loads the parent workitem again).

Other report suggests that the issue only happens to some specific workitem not ALL. Do you see the issue in multiple workitems and always reproducible? If yes, please contact support to do further investigate as our previous investigation on some reports end up with not reproducible issue and there is no conclusion at all.
Thanks

Don

Comments
Mike Shkolnik commented Nov 14 '13, 12:13 p.m.

This is not a browser cache issue. I used the browser for deleting the work items, but I am using Eclipse for everything else. Tried the browser too, of course, but both have the same problem. When a record is deleted, RTC is not removing all the links to the deleted work item. These links later create the error above and prevent the saving of any work item with those links, even if you remove the link since it won't let you save the record. I will look for a defect on jazz.net and add one if there isn't one.


Don Yang commented Nov 14 '13, 8:33 p.m.

I tested with RTC4.0.1 and 4.0.4, once I deleted the child work items, the link would be gone in the Parent workitem automatically. I tried multiple times and against multiple workitems as children and task and defect types, I have got no problem at all. So this is not a general issue. If you want to work in a defect on jazz.net, please feel free to do that although I don't think that is the best option(contacting support could be better as jazz.net defect won't guarantee a speedy investigation).


permanent link
Mike Shkolnik (9657149143) | answered Nov 15 '13, 7:30 p.m.
I have posted a defect for this item. Subscribe to it to give it more visibility.

https://jazz.net/jazz/resource/itemName/com.ibm.team.workitem.WorkItem/289994

Your answer


Register or to post your answer.