It's all about the answers!

Ask a question

Attachments problem in RTC v4

Pradnya Raste (351624) | asked Oct 30 '13, 4:53 a.m.


till 2 weeks back my RTC process was on v3. 2 weeks back it is migrated to v4 Post the migration almost everything is fine except for 1 issue which is happening specifically with 2 resources located at canada- toronto.

when we attach any file in a work item, it displays file name of the attached file. i.e. if i load file "Pradnya Raste.jpg" then the work item shows it with the same name and not the local folder in which this file is saved on my system.

for 2 of the resources at canada it is showing as "c:\users\pradnya.raste\desktop......"

I am not sure how to resolve this. please suggest.

2 answers

permanent link
Pradnya Raste (351624) | answered Nov 06 '13, 12:45 a.m.


Below are the steps need to be followed to resolve this issue. it worked completely for us.

  1. Open Internet explorer|| Go to Tools-> Internet Options-> Click on Security tab|| Under Custom -> Click on Custom level|| look for the option “Include local directory path when uploading files to a server" and select “Disable”||Click OK-> Apply-> OK||
  2. Now close internet explorer (File>Exit)
  3. Open new internet explorer check if the option 1 is showing disabled. sometimes it gets enabled automatically.
  4. Now login to RTC and try attaching a file.

@stephen Long :  Hope this works for you as well.

Don Yang commented Nov 06 '13, 3:45 a.m.

This workaround should work and many users tried this in IE8 and onwards. Using other browser should have no problem.

Stephen Long commented Nov 06 '13, 5:06 a.m.

Great spot - works a treat.

permanent link
Stephen Long (14311013) | answered Oct 30 '13, 5:06 a.m.

We had the same issue when running on v4.0.1 and with Internet Explorer 9.  Adding any attachment added the entire path and then could not be opened by any other user.  The workaround was to edit the workitem in Eclipse and rename the file to remove the path. 

We have just upgraded to v4.0.4 and the entire path is still being displayed, but all users can now open the file.


Pradnya Raste commented Oct 30 '13, 6:55 a.m.

Hi Stephen,

Thank you for the response. in my team only 2 people are facing this issue. if i upload file its getting loaded correctly. also they are not so well versed with backend and again going back and removing the same is going to be a challenge.

Your answer

Register or to post your answer.

Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.