It's all about the answers!

Ask a question

How do I save a corrupt workspace component?

Andy Jewell (24236174) | asked Oct 28 '13, 7:57 p.m.
edited Nov 04 '13, 6:16 p.m. by Stephanie Taylor (24115)
Somehow my workspace (or at least one component) seems to have gotten corrupted.  By that I mean that I've been working in the workspace normally and then suddenly (Monday morning blues?) I get this when I try to checkin my changes:

C:\Users\O386600\mberelease_preprod\master>lscm checkin .
Problem running 'checkin':
"C:\Users\O386600\mberelease_preprod\master" is not shared.
Contrary to my intuitive sense of what ought to be done, I tried to share the component after reading this question to try to "reconnect" it.  I thought since it had got there in the first place by loading it, I was a bit confused how it could have lost it's "shared" nature.  Anyhow, sharing doesn't get me anywhere:

C:\Users\O386600\mberelease_preprod\master>lscm share -r local --reshare "mbe release preprod o386600" master
. Configurations would be spread across more than 1 sandbox
after sharing

I guess if sharing is my solution, I can't really figure out what the syntax is.  The component that seems "disconnected" is "master".  I've tried various flavors of the command but haven't stumbled upon it.

If a component is suddenly flakey and I have changes in it that have not been committed, can anyone help me with what my options are?

I am using the 4.0.4 lscm client.



One answer

permanent link
Andy Jewell (24236174) | answered Oct 29 '13, 11:05 a.m.
 I shutdown the daemon, logged out and back in of lscm then executed this:

C:\Users\O386600\mberelease_preprod>lscm share -v -r local "mbe release preprod o386600" master master
Change sets:
  (1180) ---@ Andrew P Jewell "Share" 29-Oct-2013 08:00 AM
Shared successfully

I still don't know why it "lost" the share in the first place and once I commit this, will be interesting to see if I have some confusing fall out but for now, at least it's shared again.

Your answer

Register or to post your answer.