It's all about the answers!

Ask a question

CRJAZ1371E: cannot connect to repository. USers are able to connect to RTC through web but facing problem when using Eclipse client


pratibha gupta (1511115) | asked Oct 03 '13, 9:23 a.m.
edited Oct 08 '13, 3:42 p.m. by Karl Weinert (2.0k52736)
using RTC version 3.0.1 server and client.

The server url is
https://<server>/ccm/web over port 443

There is a proxy in place but the web client is working across the same proxy.

The eclipse error is as follows.
The URL "https://<server>:443/ccm/jauth-issue-token" cannot be reached.

Partial stack trace:
!ENTRY com.ibm.team.process.rcp.ui 4 0 2013-08-29 17:46:13.171
!MESSAGE Error logged from Process RCP UI:
!STACK 0
com.ibm.team.repository.common.transport.ConnectionException: CRJAZ1371E The URL "<server>:443/ccm/jauth-issue-token" cannot be reached. The server cannot be reached. The network could not connect to the server. The error is "Connection refused: connect". Contact your system administrator.
    at com.ibm.team.repository.transport.client.ClientHttpUtil.executePrimitiveRequest(ClientHttpUtil.java:1169)
    at com.ibm.team.repository.transport.client.ClientHttpUtil.executeHttpMethod(ClientHttpUtil.java:328)
    at com.ibm.team.repository.transport.client.ClientHttpUtil.access$10(ClientHttpUtil.java:297)
    at com.ibm.team.repository.transport.client.ClientHttpUtil$JAuthChallengeHandler.handleChallenge(ClientHttpUtil.java:723)
    at com.ibm.team.repository.transport.client.ClientHttpUtil.handleAuthenticationChallenge(ClientHttpUtil.java:1127)

Comments
Kevin Ramer commented Oct 03 '13, 9:54 a.m.

Some detail of the Repository Connection properties in RTC client might be helpful.  For example, the URI of the connection.   Often users will put the /web at the end of the URI, or leave the "context root" off.

Suppose I have RTC with "legacy" heritage.  Its uri would be in this form on Eclipse:

https://my-rtc-server:port/jazz
Where on the web it would be:
https://my-rtc-server:port/jazz/web


Donald Nong commented Oct 04 '13, 12:38 a.m.

If you are using a proxy on the machine, check the proxy setting of the Eclipse shell since it may pick it up automatically.


Ricky Jay commented Jan 28 '16, 7:58 a.m. | edited Mar 23 '16, 6:12 p.m.

I too is facing the same issue but none of the solutions provided above have worked for me


Donald Nong commented Jan 28 '16, 7:57 p.m.

Unless you have the exact configuration and exact issue, you'd better open a new post detailing your environment and issue so that others can help you out.

3 answers



permanent link
Don Yang (7.6k2196132) | answered Oct 08 '13, 8:08 p.m.
"There is a proxy in place but the web client is working across the same proxy."
If you mean you have configured proxy in Eclipse preference but got ignored, then it could be a known issue which was fixed in v3.0.1.3: http://www-01.ibm.com/support/docview.wss?uid=swg1PM55398

For similar issue, many users try the below and see it help:

please go to:
Windows > Preferences > Network Connection setting in the eclipse client
and review if it was set up 'Native' and no other entries except
localhost is set in the 'proxy bypass' section.
If this is the case, please change the 'Active Provider' from 'Native'
to 'Direct' and restart the eclipse client, then try again.

permanent link
Sumant Renukarya (1.1k23339) | answered Nov 27 '13, 6:22 a.m.
1. If you have set the proxy server at the system level, then there is no need to set the proxy in Eclipse 
and use 'Direct' connection in Network connections

Go to Window --> Preferences --> General --> Network connections --> Active provider --> Direct. 

2. Clean the %temp% directory.  
   
For example: C:\Documents and Settings\<user>\Local Settings\Temp  

before starting the Eclipse client with a new workspace.  

Start using a new Eclipse workspace, then change the Active Provider in Network Connection of Preference from Native to Direct. 

permanent link
pratibha gupta (1511115) | answered Dec 10 '13, 5:57 a.m.
edited Dec 10 '13, 5:59 a.m.

The likely scenario was  that the SDK being used does not support IBMCAC (and thus cannot read the Windows keystore [Windows-My]).

 

The solution for that was to upgrade the JVM what resolve the issue.

java.vendor=Sun Microsystems Inc.

java.version=1.6.0_45

java.vm.name=Java HotSpot(TM) 64-Bit Server VM

 

which also works with proxy and Windows-MY KeyStore.

Your answer


Register or to post your answer.