It's all about the answers!

Ask a question

Problems with build definition when used with Jenkins workflow/pipeline


Christian Ditscher (1314) | asked Mar 17 '16, 11:23 a.m.
edited Mar 17 '16, 11:32 a.m.
Hi

There are already several build definitions with corresponding Jenkins (free-style) jobs working without problems. In future we think about  using a workflow/pipeline in Jenkins. Therefore I tried to implement a first test pipeline. This was not successful due to the following problem...

I created a new pipeline in Jenkins and a build definition in RTC (using the existing/working build engine).
When saving the build definition in eclipse a error message is displayed (It seems that the built definition is saved nevertheless):

Error parameterizing Jenkins Job -- Error updating Hudson/Jenkins Job: Unable to read configuration of job
	
This Error is only shown when the pipeline job is selected in the build defeinition. Wehen a "free-style" jenkins job is selected no error occurs.

When trying to start a build with the pipeline job from the eclipse client the execution fails and produces the following log .
Error starting Hudson/Jenkins build for job "Pipeline_Test":
com.ibm.team.repository.common.TeamRepositoryException: Error parameterizing the Hudson/Jenkins Job
	
When the pipeline is started in Jenkins the pipeline job is finishing without problems.

Any ideas how to solve this error?


Sadly pictures I inserted are not shown :(



Comments
Lakshmi Narasimhan T V commented Mar 18 '16, 12:44 a.m.
JAZZ DEVELOPER

What is the version of RTC server, Jenkins and Pipeline plugin?

Accepted answer


permanent link
Spencer Murata (2.3k115870) | answered Mar 17 '16, 11:43 a.m.
FORUM MODERATOR / JAZZ DEVELOPER
 Sounds like a permission problem from the Jenkins side.  It is trying to read the Jenkins XML file to determine information on the job as well as attempting to make the job a parameterized one.  Since it has problem reading/writing that data to Jenkins I would guess that the jobs are protected from the RTC user attempting to read the Jenkins server.

~Spencer
Christian Ditscher selected this answer as the correct answer

Comments
Christian Ditscher commented Mar 18 '16, 3:41 a.m. | edited Mar 18 '16, 3:43 a.m.

Yeah.. the first answer solved the Problem.

After playing around with the access rights I found the solution to my problem. The Build user was missing the right to "Configure" Jobs.

Saving the Build definition is now successful and a message is displayed:
Hudson/Jenkins Job "...." was updated. The "buildResultUUID" parameter was added.

(I already had added the parameter manually before but that adding from inside the Build definition seems to be necessary.)


Also I can start the Job from Eclipse which is executed successfully :)


sam detweiler commented Mar 18 '16, 9:00 a.m.

Sad that you didn't get the right error message..

One other answer



permanent link
Lakshmi Narasimhan T V (4115) | answered Mar 17 '16, 12:48 p.m.
JAZZ DEVELOPER
Can you create a jazz.net work item and attach the server logs? Please include the version details for RTC server, Jenkins, Pipeline plugin and Team Concert Jenkins plugin.

Your answer


Register or to post your answer.