It's all about the answers!

Ask a question

problems encountered while moving resources


john norris (20723542) | asked Sep 11 '13, 4:57 a.m.

Hi, using RTC 4.0.1 with eclipse. I am seeing a problem that I have not seen before and I wondered if anyone has any ideas of what is causing it. It may be an eclipse problem.

I have existing projects within RTC and can make changes and deliver those changes. I have just created a new project in RTC and now wish to share that project from eclipse. So Team->Share project, select component, select eclipse project (there are several - each will go into a new component). I get an error of "problems encountered while moving resources". Under Pending Changes, *I think* all of the files are under Unresolved along with the top level directory under Outgoing, linked to the workitem (import). I can check in the Unresolved.

Googling finds an IBM item about readonly files but I do not think that is the problem.

So does anyone know what causes the error message in eclipse.

Regards,

John


Comments
Krzysztof Kaźmierczyk commented Sep 11 '13, 6:06 a.m. | edited Sep 11 '13, 6:07 a.m.

Hi John,
Can you look if you have any errors in <your-workspace>/metadata/.log file?


john norris commented Sep 11 '13, 6:31 a.m.

That is a good point. So the problem seems to be that access is denied on the .project file. Yet I can edit the file.

Of the four eclipse projects that I am adding to Jazz, only one works as expected. And the only difference is that project has .project in the top level directory ie c:\dir\component1\.project whereas the others (which fail) are c:\dir\component\dir\.project.

Is this going to cause eclipse a problem?

As an aside, the project that works normally goes straight to an "outgoing" state and the Navigator view in Eclipse shows the workspace. The other projects that I have had to checkin manually do not show the workstream.


john norris commented Sep 11 '13, 6:47 a.m.

Well I just discarded the change for one of the failing Shares and moved the contents up one level and still get same problem as before so the position of the .project in the directory structure is not to blame.

So I have no idea why a .project in one project is writable and in three other projects is not.

One answer



permanent link
john norris (20723542) | answered Sep 11 '13, 8:10 a.m.
Not sure what the problem was but the eclipse files had been created using maven. I deleted the eclipse .project, .classpath and settings files and rerun maven eclipse:eclipse. Then imported  into eclipse and then shared and now all worked as expected.

Your answer


Register or to post your answer.