It's all about the answers!

Ask a question

Unable to start Jazz 4.0.5 as a service on Windows Server 2012


Romuald Tisserand (738) | asked Mar 20 '14, 5:04 a.m.
retagged Mar 20 '14, 10:39 a.m. by Laura W. Hinson (16126)
Hi,
I've successfully installed Jazz RTC 4.0.5 on Windows 7 and managed to start it as a Windows Service, and it works fine. Unfortunately, the same procedure doesn't work on Windows Server 2012.

Pre-condition: Jazz RTC is correctly installed and works fine if started manually.

I followed the instructions from the official IBM documentation: http://pic.dhe.ibm.com/infocenter/clmhelp/v4r0/index.jsp?topic=%2Fcom.ibm.jazz.install.doc%2Ftopics%2Ft_run_rqm64_win_service.html

But it seems a bit incomplete, so I also executed these instructions: https://jazz.net/help-dev/rational-insight/index.jsp?topic=%2Fcom.ibm.jazz.install.doc%2Ftopics%2Fc_deploying_tomcat.html

My Windows service is well created with all necessary parameters. The computer has 6 GB or RAM. Once the changes made, I checked Jazz RTC starts well again when it is manually run, and it does.

But when I try to start the Tomcat 7 Windows Service, the JVM initialisation fails, with the error code: JVMJ9VM015W. I insist, I do NOT get this error when Jazz is started manually.

Thanks.


Comments
Krzysztof Kaźmierczyk commented Mar 20 '14, 5:17 a.m.

Hi Romuald,
There are different root causes of JVMJ9VM015W. Where do you see this error JVMJ9VM015W? In any log file? Please provide us the full error message to better troubleshoot it.


Romuald Tisserand commented Mar 20 '14, 5:43 a.m. | edited Mar 20 '14, 6:45 a.m.

Hi Krzysztof,
Yes in a log file: #root path#\JazzTeamServer\server\tomcat\logs\tomcat7-stderr.2014-03-19

Full content is:

2014-03-19 17:22:56 Commons Daemon procrun stderr initializedJVMJ9VM015W Erreur d'initialisation de la bibliothŠque j9gc24(2) : Echec de l'instanciation du segment. 4G demand‚

In English, this message is: "Initialization error if the library j9gc24(2): Failed to instantiate segment. 4g requested."

That's all, end of story.


Krzysztof Kaźmierczyk commented Mar 20 '14, 6:22 a.m.

Romuald,
It seems that due to any reason you Virtual Machine for Jazz is not able to allocate 4GB of memory. How much free memory you have on your machine when attempting to start RTC server?
Anyway it is strange for me that it starts when running from command line.


Romuald Tisserand commented Mar 20 '14, 6:33 a.m.

All is here Krzysztof. Jazz runs in this very moment, just launched through the server.startup batch. The server has 6 GB of RAM and Jazz is the sole installed application.

Right now, with Jazz working, the PC consumes 3GB of RAMn has 3GB Free, and Jazz runs 2GB. This means the server only consumes 1GB and 5GB Free when Jazz does not run.


sam detweiler commented Mar 20 '14, 6:53 a.m.

how much memory is available to the service?


Ralph Schoon commented Mar 20 '14, 6:56 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

If you can start it using the script, but it won't start as service, one reason could be that you did not locate all the settings in the startup script and made sure they are also used in the service. This could cause defaults that might lead to memory allocation issues.


Romuald Tisserand commented Mar 20 '14, 7:06 a.m.

Hi Sam,
Thanks to help. I've never seen anything about memory allocation for services, if you know how to check this, it'd be great!


Romuald Tisserand commented Mar 20 '14, 7:19 a.m.

Thanks to help Ralph.

I've checked again:
- in all teamserver.properties files, all values containing "conf/" are well absolute pathes
- in all log4j.properties files, all values containing "logs/" are well absolute pathes
All with forward slash, of course.

I do not really see what I can further do in this area.


Ralph Schoon commented Mar 20 '14, 7:52 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

If I remember correctly, you where also to look into the server.startup file and bring the Java Options over e.g. the lines with

set JAVA_OPTS=%JAVA_OPTS% -Xmx4G
set JAVA_OPTS=%JAVA_OPTS% -Xms4G
set JAVA_OPTS=%JAVA_OPTS% -Xmn512M
These are important too and will not be automatically set in the service startup, if you don't specify them.....


Romuald Tisserand commented Mar 20 '14, 8:34 a.m.

Thanks, they are, here is the full Java parameters list:

-Dcatalina.base=C:\Jazz\JazzTeamServer\server\tomcat
-Dcatalina.home=C:\Jazz\JazzTeamServer\server\tomcat
-Djava.endorsed.dirs=C:\Jazz\JazzTeamServer\server\tomcat\endorsed
-Djava.io.tmpdir=C:\Jazz\JazzTeamServer\server\tomcat\temp
-Djava.util.logging.manager=org.apache.juli.ClassLoaderLogManager
-Djava.util.logging.config.file=C:\Jazz\JazzTeamServer\server\tomcat\conf\logging.properties
-DJAZZ_HOME=file:///C:/Jazz/JazzTeamServer/server/conf
-Djava.awt.headless=true
-Dorg.eclipse.emf.ecore.plugin.EcorePlugin.doNotLoadResourcesPlugin=true
-Dcom.ibm.team.repository.tempDir=C:\Program Files\IBM\JazzTeamServer\server\tomcat\temp
-Djazz.connector.sslProtocol=SSL_TLS
-Djazz.connector.algorithm=IbmX509
-Dlog4j.configuration=file:///C:/Jazz/JazzTeamServer/server/conf/startup_log4j.properties
-Xgcpolicy:gencon
-Xcompressedrefs
-Xgc:preferredHeapBase=0x100000000
-XX:MaxDirectMemorySize=1G
-Xmx4G
-Xms4G
-Xmn512M

showing 5 of 10 show 5 more comments

Accepted answer


permanent link
Patrick Remington (2013) | answered Mar 20 '14, 11:01 a.m.
FORUM MODERATOR / JAZZ DEVELOPER
edited Mar 20 '14, 11:23 a.m.

Romuald,

I don't know if it will make any difference to your situation, but I noticed that you referred to the information in the V4R0 information center for the topic instead of the V4R0M5 information center.  In comparing the topics from the two versions, I see some additional instructions in the V4R0M5 version, some having to do with the initial and maximum memory pools. Look at http://pic.dhe.ibm.com/infocenter/clmhelp/v4r0m5/index.jsp?re=1&topic=/com.ibm.jazz.install.doc/topics/t_run_rqm64_win_service.html&scope=null

Romuald Tisserand selected this answer as the correct answer

Comments
Romuald Tisserand commented Mar 20 '14, 12:12 p.m. | edited Mar 20 '14, 12:14 p.m.

This makes all the diffence Patrick, it works, fantastic! Thanks a lot.

To be short : removing all memory tricks from the Java parameters in the tomcat7 service window does the trick.


Ralph Schoon commented Mar 20 '14, 12:13 p.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

Great to hear you got it working.


Renato Mori commented Jul 23 '14, 12:38 a.m.
JAZZ DEVELOPER

Hi Romuald
I'm having a similar issue, but still can make it working fine.
The performance of clm is very poor.
can you take a look in my post Tomcat as Service Issue ?
Also, what do you mean with: "removing all memory tricks"

Thanks!


Romuald Tisserand commented Sep 05 '14, 9:36 a.m.

Hi Renato,
I'm so sorry to not having seen your message before. Even if it's more than a year old, the solution was to remove all Xms, Xmx, etc settings from the service.

Your answer


Register or to post your answer.