It's all about the answers!

Ask a question

RQM upgrade: requirement upgrade question


Don Yang (7.1k2188121) | asked Aug 28 '13, 4:16 a.m.
edited Aug 28 '13, 4:17 a.m.
The upgrade is from RQM2.x to 3.x then to 4.x.

The user has  requirements in RQM 2. During the upgrade of RQM 2 to RQM 3,
there is a step to refactor requirements, which takes the requirements
from RQM 2 and puts them into RRC 3.

What the user wants to know, is, is it possible to refactor the requirements
after the upgrade to CLM 4, or can it only be done when upgrading RQM 2
to RQM/RRC 3? They have tried it and are getting errors, however, the
errors may be environmental. So they like to know whether it s
possible or not.

Accepted answer


permanent link
Paul Ellis (1.3k613) | answered Aug 29 '13, 11:27 a.m.
JAZZ DEVELOPER
Hi Don,

To further elaborate what John is saying, it is only possible to do this between 2.x and 3.x as this is when we moved the requirements out of RQM and into RRC.

As moving from 2.x to 4.x is very much a 2-step process, then you must complete this step between 2.x and 3.x. 
http://pic.dhe.ibm.com/infocenter/clmhelp/v4r0/topic/com.ibm.jazz.install.doc/topics/c_upgrade_to_301.html

The assumption here is that you wouldn't have requirements in your RQM database by the time you get to 4.x.  As you noted, the interactive upgrade guide has the following section:

Choose from the following about your Rational Quality Manager environment, which produces a section 22 - See:

Migrate your internal requirements to the RM application

See:http://pic.dhe.ibm.com/infocenter/clmhelp/v3r0m1/topic/com.ibm.jazz.install.doc/topics/roadmap_clm_upgrade.html

However, it seems like you have missed this step as you have an error.  If you post the error itself, obfuscating any details you wish to remain private, then we might be able to explain the error.
I fear though that you've already performed this action , which would mean you should re-do the procedure.  If that is not possible, I'd contact Rational Client Support before proceeding further.

Kind regards,
Paul

Don Yang selected this answer as the correct answer

Comments
Don Yang commented Aug 29 '13, 7:21 p.m.

Thanks John and Paul for the confirmations.
This has been done in VM testing environment and when moving requirement to RRC during RQM 2 to CLM3.0.1.x, it worked. So will suggest the user to do the step during v2.x to 3.x instead of in 4.x.

One other answer



permanent link
John Carolan (71616) | answered Aug 28 '13, 5:40 a.m.
Hi Don,

You should fully complete the steps of the upgrade to 3.x (the 4.0.3 upgrade documentation specifies the latest fix pack release of version 3.0.1) before starting the upgrade to 4.x. Attempting to skip any steps until after the 4.x upgrade will probably cause problems for your user.

Best Regards,

John

Your answer


Register or to post your answer.