It's all about the answers!

Ask a question

How to use a UNC path for a Shared Location on a QM server running on Linux?

Dustan Daniel (3921623) | asked Aug 06 '13, 8:20 a.m.

Our QM 4.0.3 server is running on RHEL. I have configured QM Shared Locations to access windows shares using cifs, i.e.
mount -t cifs //machinename/mymachine -o username=userid,password=XXXXXX /mnt/WinShare. This works perfectly.

However, one scenario I am faced with, is I have a team that uses Odin Axe Test Manager to import RFT test scripts directly into RQM. The integration between Axe-RQM-RFT requires UNC paths to be set. Once the scripts are imported into QM, they contain UNC paths to the script location. When RQM is used for execution, what results is projectnotfound exception.

The screenshot belows shows a RFT script imported into RQM using axe. The Shared Resource Location is a UNC path that is not editable. This is dilemma I am faced with.

Is it possible to use a UNC path set as a Shared Location on a QM server that is running on linux? \\nldvecm01\Share as opposed to /mnt/Share?

One answer

permanent link
Ted Mayer (47638) | answered Aug 06 '13, 4:25 p.m.

Hello Dustan,

You should be able to use the UNC paths as a shared location, you can use Samba to mount a Windows share on Linux. One other similar article that I had seen was the following:

I hope that this helps,



Dustan Daniel commented Aug 07 '13, 2:16 a.m. | edited Aug 07 '13, 2:18 a.m.

Hi Ted, thanks for your response. As mentioned I have mounted the windows shares using CIFS. This works for all other instances (normal RFT on Windows -RQM on Linux integration) except for the team using Odin Axe tool.

The format appears to need to be in UNC format. UNC

I am able to connect to Shared resources using the linux format eg. /mnt/something. But when test scripts are imported directly from Axe, they maintain their windows UNC location.

I need to know if it is possible to use this UNC format directly from the QM web gui as per the screenshot above? The team affected by this has heard from an Odin developer that there may be a solution using smbclient. Not sure yet how this will work directly from the QM web gui. If I come right, I will be sure to post an update to my forum question.

I have found a manual workaround in the time being, by moving the Axe project files and editing each test script, but due to the volume of test scripts this is not really a feasible option.

William Chen commented Aug 09 '13, 12:01 p.m.

Hi Dustan,

This is a common problem on Linux-based Shared Location configuration. You would receive the error "project not found" due to permission issues with Shared Location. Be sure to allow the administrator that is running the RQM as a service or process to have full permissions to the network folders you would like to add to your Shared Locations.

Can you confirm if the Odin Axe tool would inherit the same user permissions?


Your answer

Register or to post your answer.