It's all about the answers!

Ask a question

Taskboard loading fails in web client after migration to 4.0.3

Miroslav Zaninovic (36727) | asked Jul 25 '13, 4:16 a.m.

We upgraded RTC from to  4.0.3. RTC project use Agility@Scale template.
After migration Taskboard view in plans doesn't work in web client. In eclipse client everything is OK.
Taskboard use filters (options):
Group by Owner
Exclude Empty Group
Exclude Empty Items from Sub-Iterations
Sort by Priority

Unfortunately, when I run plan first time  in web browser, plan display wrong data. When I click option Set Column Adjustments As Default, plan refreshes and shows correct data.

Issue occurs in IE  and 9, Mozilla and Chrome.
Only Chrome display error
TypeError: Cannot call method 'isTopLevel' of null
TypeError: Cannot call method 'isTopLevel' of null
at dojo.declare.isExecutionItem (https://hostname/ccm/web/_js/?exclude=G~H&
at dojo.declare.timeline (https://hostname/ccm/web/_js/?exclude=G~H&
at dojo.declare.initializeScheduler (https://hostname/ccm/web/_js/?exclude=G~H&
at dojo.declare.initialize (https://hostname/ccm/web/_js/?exclude=G~H&
at dojo.declare.doInitializeAttribute2 (https://hostname/ccm/web/_js/?exclude=G~H&
at null. (https://hostname/ccm/web/_js/?exclude=G~H&
at null.fFunction (https://hostname/ccm/web/_js/?include=G~&etag=IcTH8basNRJ_en_US&_proxyURL=%2Fccm&ss=CmDDU:15:15340)
at null. (https://hostname/ccm/web/_js/?exclude=G~H&
at https://hostname/ccm/web/_js/?include=G~&etag=IcTH8basNRJ_en_US&_proxyURL=%2Fccm&ss=CmDDU:15:15340

There is no messages in websphare and application logs.
I tried to debug all web browser but only this was captured

PlanAttributeRegistry: may be broken because of dependency on
PlanAttributeRegistry: may be broken because of dependency on
PlanAttributeRegistry: may be broken because of dependency on planning/source/

Any advice how to resolve the issue?

One answer

permanent link
Stephanie Bagot (2.1k1513) | answered Jul 25 '13, 6:10 p.m.
I would suggest opening up a PMR with IBM Support to resolve this issue.

Miroslav Zaninovic commented Jul 26 '13, 3:34 a.m.

Thank you Stephanie!
Do you mean real PMR or just Defect for version 4.0.3?

Stephanie Bagot commented Jul 26 '13, 8:06 a.m.

A real PMR to work directly with IBM Support.
We will have to look at your ccm.log file, and most likely add some trace to determine the root cause.

Your answer

Register or to post your answer.

Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.