It's all about the answers!

Ask a question

cc to rtc import full history error


Lucy Kirk (31157) | asked Jul 17 '13, 6:47 a.m.

So, on running the importer with full history the stream gets created but when it does the actual 'build/syhchronise' we get the error below.

Any ideas?

problem running 'synchronizeStream':
Synchronization blocked by error:
javax.wvcm.WvcmException: The synchronization process failed to read the standard output of the "/opt/rational/clearcase/bin/cleartool" command:
 
/opt/rational/clearcase/bin/cleartool diffbl -activities oid:f9cb2663.3e4b4092.93b3.9f:ce:9c:72:35:7a@vobuuid:6bdc7a50.ee4a4e49.867b.c1:85:6e:70:f2:87 oid:c522cb5c.653d4616.9c3a.a1:35:de:6a:c2:77@vobuuid:6bdc7a50.ee4a4e49.867b.c1:85:6e:70:f2:87
Comparing the following:
  AUTOMATION_UTILS_2009_06_26@/vob/TOOLS_UTILITIES_PROJECTS
  AUTOMATION_UTILS_2009_10_31@/vob/TOOLS_UTILITIES_PROJECTS
Differences:

current working directory: /view/DO_NOT_USE_AUTOMATION_UTILS_MAIN_Integration
command result status: 0
command duration: 211 ms
process environment: APPS_PATH=/usr/atria/bin|ATRIA_WEB_GUI=1|CONNECTOR_SYNCH=1|CSHENV_SET=true|DISPLAY=:1.0|EDITOR=vi|FULLENV=false|FULLPATH=true|GCONF_GLOBAL_LOCKS=1|GCONF_SHARED_LOCKS=1|GROUP=eng|G_BROKEN_FILENAMES=1|HOME=/users/lukirk|HOST=poc-gpk-ndsvob1|HOSTNAME=poc-gpk-ndsvob1|HOSTTYPE=x86_64-linux|IBM_JAVA_COMMAND_LINE=/users/lukirk/jazz/client/eclipse/jdk/bin/java -jar /users/lukirk/jazz/buildsystem/buildengine/eclipse/plugins/org.eclipse.equinox.launcher_1.1.1.R36x_v20101122_1400.jar -repository https://rtp-scmrtc-ccm1.cisco.com:9443/ccm1/ -userId ccsync.gen -passwordFile ccsync.gen.cred.txt -engineUUID _VNRq4O6zEeKxB9KAtTki7Q -sleepTime 120|INPUTRC=/etc/inputrc|KDEDIR=/usr|KDE_IS_PRELINKED=1|LANG=en_US.UTF-8|LC_ALL=C|LD_LIBRARY_PATH=/users/lukirk/jazz/client/eclipse/jdk/jre/bin/j9vm:/users/lukirk/jazz/client/eclipse/jdk/jre/bin:/users/lukirk/jazz/client/eclipse/jdk/jre/lib/i386:/usr/X11R6/lib|LESSOPEN=|/usr/bin/lesspipe.sh %s|LOCAL_PATH=/usr/cisco/bin /usr/cisco/etc|LOGNAME=lukirk|LS_COLORS=no=00:fi=00:di=00;34:ln=00;36:pi=40;33:so=00;35:bd=40;33;01:cd=40;33;01:or=01;05;37;41:mi=01;05;37;41:ex=00;32:*.cmd=00;32:*.exe=00;32:*.com=00;32:*.btm=00;32:*.bat=00;32:*.sh=00;32:*.csh=00;32:*.tar=00;31:*.tgz=00;31:*.arj=00;31:*.taz=00;31:*.lzh=00;31:*.zip=00;31:*.z=00;31:*.Z=00;31:*.gz=00;31:*.bz2=00;31:*.bz=00;31:*.tz=00;31:*.rpm=00;31:*.cpio=00;31:*.jpg=00;35:*.gif=00;35:*.bmp=00;35:*.xbm=00;35:*.xpm=00;35:*.png=00;35:*.tif=00;35:|MACHTYPE=x86_64|MAIL=/var/spool/mail/lukirk|MANPATH=/sw/current/man:/usr/share/man:/usr/cisco/man:/usr/man|MOZILLA_FIVE_HOME=/usr/lib/xulrunner-1.9.2|NNTPSERVER=usenet.cisco.com|OSTYPE=linux|OS_PATH=/bin /usr/X11R6/bin /usr/sbin /sbin /usr/bin /usr/cisco/bin|PATH=/usr/kerberos/bin:/router/bin:/usr/atria/bin:/usr/cisco/bin:/usr/cisco/etc:/users/lukirk/bin:/bin:/usr/X11R6/bin:/usr/sbin:/sbin:/usr/bin:/usr/cisco/bin:.|PRINTER=lp|PWD=/users/lukirk/ClearCaseSynchronizer/_s047we67EeKLa99053pEpg.synchronizer|REMOTEHOST=ams3-vpn-dhcp6936.cisco.com|SHELL=/bin/csh|SHLVL=2|SSH_ASKPASS=/usr/libexec/openssh/gnome-ssh-askpass|SSH_CLIENT=10.61.91.23 55458 22|SSH_CONNECTION=10.61.91.23 55458 10.52.61.71 22|SSH_TTY=/dev/pts/2|SW_PATH=/router/bin|TERM=xterm|USER=lukirk|USER_PATH=~/bin|VAS_LOGONSERVER=adc-aer1-c1-5.cisco.com|VENDOR=unknown|VISUAL=vi|VNCDESKTOP=poc-gpk-ndsvob1:1 (lukirk)|WINDOWID=6291494|XTERM_SHELL=/bin/csh|XTERM_VERSION=XTerm(215)|_=/usr/bin/nohup|
javax.wvcm.WvcmException: Output from cleartool command could not be processed because it contains a byte sequence not legal for the given character set.  Ensure that any filenames being processed by cleartool contain only characters legal for the specified locale.
java.nio.charset.MalformedInputException: Input length = 1
Build failed. Exit value was 3.

2 answers



permanent link
Paul Komar (421) | answered Aug 12 '13, 4:22 p.m.
To diagnose this kind of problem do the following:
. Run the failing command at the command line redirecting the output to a file
. Look for problematic characters in the line after the last line reported in the sync/build log.


permanent link
Josh Crawford (984515) | answered Jul 17 '13, 12:50 p.m.
 Hi Lucy,  this is a problem with the Lang environment variable.  In your stack trace I can see this is set to UTF- 8.  This should be set to en_US.ISO-8859-1.  This needs to be done for the JBE process which is running the synchronization operation.  To do this you can use the following process. 

Stop the sync engine if it is running ( you can find the process by something like 'ps -ef | grep buildengine' )
Close RTC eclipse client
Set LANG environment variable in your terminal, export it. ( 'setenv LANG en_US.ISO-8859-1' or 'export LANG=en_US.ISO-8859-1' etc.)
Start RTC eclipse client from the terminal
Verify the LANG env. variable is set as expected, by 'cat /proc/<RTC eclipse client process>/environ' and find LANG var.
Go to ClearCase Sync. view, select your sync. stream and start sync. engine
Again, verify  the LANG env. variable is set as expected for the sync engine process
Run sync

Comments
Lucy Kirk commented Jul 31 '13, 9:19 a.m. | edited Aug 01 '13, 6:38 p.m.

Hi

Thanks for this. We've tried it, made the changes and re-tried the import and it still errors. Are there any other work rounds for this error or do you think it could be a bug??

Thanks

Lucy


Geoffrey Clemm commented Aug 01 '13, 6:37 p.m. | edited Aug 01 '13, 6:38 p.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

It might be quickest to just work with support.  One thing to try next is to run the command that is failing in a shell window on your sync host, and see if there is anything strange in the results.  I.e. the command:

/opt/rational/clearcase/bin/cleartool diffbl -activities oid:f9cb2663.3e4b4092.93b3.9f:ce:9c:72:35:7a@vobuuid:6bdc7a50.ee4a4e49.867b.c1:85:6e:70:f2:87 oid:c522cb5c.653d4616.9c3a.a1:35:de:6a:c2:77@vobuuid:6bdc7a50.ee4a4e49.867b.c1:85:6e:70:f2:87


Lucy Kirk commented Aug 05 '13, 6:45 a.m.

thank you, i believe we have now raised a call.

Your answer


Register or to post your answer.