It's all about the answers!

Ask a question

Upgrade error


Yehiel Glass (25528786) | asked Jun 12 '13, 10:40 a.m.
Hello,
I'm upgrading now RTC from 3.0.1.3 to 4.0.2 .
Because of 4.0.2 version needs WAS 8 - I'm installing the 4.0.2 on a new WAS.
JTS upgrading seceded but CCM gave the following error:
[wasadm@scmt <> /products/IBM/JAZZ/402/JazzTeamServer/server]$ upgrade/ccm/ccm_upgrade.sh -oldApplicationHome /products/IBM/JazzTeamServer/server/conf -updateTomcatFiles no
....
Repo Tools
Provisioning using "./conf/ccm/provision_profiles".
  Change and Configuration Management - Core Libraries, Version 4.0.2 (RTC-I20130222-1633)
  Jazz Foundation - Core Libraries, Version 4.0.2 (RJF-I20130222-1204)

CRJAZ1363I Loading the configuration from "bundleresource://363.fwk1540447185/teamserver.properties".
Validating JTS configuration files...
Checking the old application version...
CRJAZ2129E An error occurred while checking the version of the old application. More information "The version string "  -Dcom.ibm.team.repotools.rcp.allowInvalidBundles=true" is not properly formatted.".
CRJAZ2123E The old application version could not be determined.  Verify that the oldApplicationHome is pointed at the correct installation and specify the version using the oldApplicationVersion parameter.

The ccm upgrade failed at step 0.  Correct the problem and run the script again starting at step 0.

Variable oldApplicationHome is pointing to the right path.
I removed our custom plugins from /products/IBM/JazzTeamServer/server/conf/ccm/sites/
and provision_profiles libraries.
How can I uninstall plugin without running the application ?
What should I do ?



Comments
Indradri Basu commented Jun 12 '13, 1:01 p.m.

Hi Yehiel, it would be great if you can post back if the technote Kot has pointed out has resolved the problem.

Accepted answer


permanent link
Kot T. (1.5k11219) | answered Jun 12 '13, 11:12 a.m.
JAZZ DEVELOPER
edited Sep 29 '20, 3:13 p.m.

The following technote talks about similar error when upgrading to 4.0.

http://www-01.ibm.com/support/docview.wss?uid=swg21608026

New URL to the technote: https://supportcontent.ibm.com/node/213009

Yehiel Glass selected this answer as the correct answer

Comments
Josh Crawford commented Jun 12 '13, 1:33 p.m.

I agree with Kot.  This has resolved the same error for me in the past a couple of times.  


Indradri Basu commented Jun 12 '13, 1:45 p.m.

I am sure it does most of the time but believe me I hit a scenario where it didn't


1
Indradri Basu commented Jun 12 '13, 2:27 p.m. | edited Jun 12 '13, 2:59 p.m.

Hey Josh/Kot, no offense intended here and to share my past experience, take a look at this post. I am pretty sure I did tried that technote and after running the repotools with -clean, it complained about the missing bundles and was still stuck with the upgrade.

One other answer



permanent link
Yehiel Glass (25528786) | answered Jun 13 '13, 4:07 a.m.
Hello Kot,
Your link solved the problem and I finished the upgrade process successfully.
Thanks !

Your answer


Register or to post your answer.