It's all about the answers!

Ask a question

[RTC] Web Quick Search - Error: Unknown type


Alvaro Riera (4011218) | asked May 27 '13, 6:31 a.m.
 Morning,

I have a problem with quick search on web client.
Steps to get Error: Unknown Type
1.- Im in Project Area "A"
2.- Introduce a workitem ID of a different Project Area (B). Dont wait till query results, just pulse ENTER
3.- Web Cliente goes to the workitem details but project area is still "A" instead "B".
4.- Error: Unknown type. I can do nothing with this workitem.

Any idea to solve it pls?

Thank you!

One answer



permanent link
Eric Jodet (6.3k5111120) | answered May 27 '13, 9:31 a.m.
JAZZ DEVELOPER
 Hello Alavaro,
may you please provide more detailed steps, so we can try and reproduce the issue?
ex:
- create Project Area A - template SCRUM
(...)
- WebUI : go to ...
- create a work item of type ...
(..)

and possibly add screen cap of the error

Thanks
Eric.

Comments
Alvaro Riera commented May 28 '13, 2:04 a.m.

Morning!


I can reproduce with areas of all templates.

Im going to try to explain better :) 

Im in Project Area A, doesnt matter the section.
For example:
A

And i quick search the workitem 3954 that belongs to another PA (B)
Workitem of B

The workitems seems to be loaded correctly, but the project area is wrong:



Alvaro Riera commented May 28 '13, 2:08 a.m. | edited May 28 '13, 2:13 a.m.

error  



We cant work with this workitem... always shows that error.

Now, if u enter through the query results, the workitem is well loaded.
OK

Hope it can help u to reproduce this issue.

Thank you!


Eric Jodet commented May 28 '13, 2:58 a.m.
JAZZ DEVELOPER

 Hello Alvaro,

now I have a better idea of the context / steps.
may you please tell me if project area A (for 3963)
has the same template as project area B (for 3954)
and if PAs use out-of-the-box templates or if you customized them (like create a new type)
Looking at ticket 3954 - assuming you're using customized PA


Alvaro Riera commented May 28 '13, 3:03 a.m. | edited May 28 '13, 3:09 a.m.

Yes, same template and yes its customized but the base is a procesformalpm.process.ibm.com


Project Area "A" only have workitemtype com.ibm.team.workitem.workItemType.peticion_soporte
Project Area "B" only have workitemtype com.ibm.team.workitem.workItemType.ticket
 

I can try in a virtual to create 2 project areas with same base template with no customization...

Ill tell you the result, just a few minutes...


ouch, its RTC 4.0.1  i forgot say it before :)
 


Eric Jodet commented May 28 '13, 3:09 a.m.
JAZZ DEVELOPER

 ok - well, I would expect an unknown type error if PA A and PA B do NOT have the same template.

If they have the same template... we'll see the result of your use case.


Alvaro Riera commented May 28 '13, 3:15 a.m. | edited May 28 '13, 3:15 a.m.

 I think the issue is that when RTC loads the workitem when clicking "lens icon" or hitting ENTER key doesnt refresh the project area.

It keeps the actual project area where you are at this moment, not the project area of the workitem you have searched.

It should work as it does when clicking the query result hyperlink.


Alvaro Riera commented May 28 '13, 3:46 a.m.

 Tried with 2 areas with same custom template (same workitemtypes) and the error doesnt show when item is loaded but yes when i try to save changes...


Trying with 2 areas with original procesformalpm.process.ibm.com 


Alvaro Riera commented May 28 '13, 3:55 a.m.

 Here we go:


A:


Alvaro Riera commented May 28 '13, 4:10 a.m. | edited May 28 '13, 4:16 a.m.

 Here we go:


A:

B:


Creating Defect in B:

Ok, we have ID: 777 in project area B:


Now we quicksearch 777 from project area A, hit ENTER or click lens icon. Do not click query result:

Ok, workitem 777 of Project Area B is loaded, but the Project Area is still A!

Trying to modify workitem should fails with custom temps
Ok, with base templates it works !!!




Alvaro Riera commented May 28 '13, 4:13 a.m. | edited May 28 '13, 4:16 a.m.

I have tried between 2 project areas with same custom templates (same workitem "Ticket", same workitemtype, attributes, etc... all the same, just created with same custom template with no modifications after), and it shows  Error: Unknown type following those steps.


Any idea how to solve it ??? :(

Remember that clicking query result works just fine with custom templates too ...

Thank you very much!


Eric Jodet commented May 28 '13, 4:32 a.m.
JAZZ DEVELOPER

 Hello Alvaro,

I guess if you have detailed steps to repro and can share your template,
you may open a defect so the dev team has a closer look.

Thanks


showing 5 of 12 show 7 more comments

Your answer


Register or to post your answer.