It's all about the answers!

Ask a question

What's missing if CQ Bridge reports "This service does not provide any pickers"?


Guido Schneider (3.3k137699) | asked Apr 27 '13, 4:52 a.m.
We have connected RTC 4.0.1 with CQ 8.0.0.4. We can login over the OSLC in CQ. We are able to run CQ-Querys, to display CQ-Charts, to run CQ BIRT reports etc. out of RTC Dashboards. We are also able to link RTC Workitems to CQ "Related Change Requests" directly out of the work item editor links tab. The rich hover is functioning well and displaying CQ information correct.

BUT: If I want to link a workitem with a "Affected by Defect" link, I get the message "This service does not provide any pickers".

CQ Bridge - Affected by defect

The silly thing is, this was working for month. And we have not changes anything on RTC as well as on CQ site, as much as I can remember.

Has anybody any Idea where I can debug? What OSLC statement is sent over the wire to get the value picker from CQ etc..



Comments
Indradri Basu commented Apr 28 '13, 2:22 p.m.

Like throwing a stone into the dark, have you tried looking into FireBug output ?


Guido Schneider commented Apr 28 '13, 3:40 p.m.

No. But is a good idea.


Guido Schneider commented May 25 '13, 12:05 a.m.

I had this issue today again.

What helped was a reboot of the CQ Server.

Could anybody explain how this technically works, so I can try to better find the Problem in case it happens again?

I will open a PMR.

One answer



permanent link
Matthew Alexander (18126) | answered May 28 '13, 1:54 p.m.
JAZZ DEVELOPER
Hi Guido,

I asked some folks about the error you are seeing and received this response:

- - - - -
RTC is looking for a CQ selection dialog with oslc:usage

http://open-services.net/ns/cm#defect

I thought we provided one in our service provider document, however, so I'm not sure what's wrong.

https://server:9443/cqweb/oslc/repo/myRepo/db/SAMPL/

<selectionDialog>
                    <Dialog>
                        <dc:title>Choose ClearQuest Record</dc:title>
                        <dc:description>Web dialog for finding and selecting ClearQuest Record records</dc:description>
                        <label>ClearQuest Record</label>
                        <dialog rdf:resource="https://server:9443/cqweb/oslc/repo/myRepo/db/SAMPL/record-type/16777224/selectionDialog?dc%3Atype=cq.repo.cq-rectype%3A16777224%40lb_sql%2FSAMPL&amp;restrictType=false"/>
                        <hintWidth>640px</hintWidth>
                        <hintHeight>540px</hintHeight>
                        <resourceType rdf:resource="http://open-services.net/ns/cm#ChangeRequest"/>
                        <usage rdf:resource="http://open-services.net/ns/core#default"/>
                        <usage rdf:resource="http://open-services.net/ns/cm#defect"/>
                        <usage rdf:resource="http://open-services.net/ns/cm#planItem"/>
                        <usage rdf:resource="http://open-services.net/ns/cm#task"/>
                        <usage rdf:resource="http://open-services.net/ns/cm#requirementsChangeRequest"/>
                    </Dialog>
                </selectionDialog>
- - - - -
 

Comments
Guido Schneider commented Jun 02 '13, 9:51 a.m.

Thanks for searching.

I had the issue a second time. Nobody was able to create  a link "Affected by Defect" to CQ.
I rebooted the CQ webserver and ten it worked again.

It looks like CQ is loosing somewhere the knowledge about what it provides.

You're writting about a "service document". Where is this stored on a CQ web server? What's the name of it?

I opened a PMR. Maybe support find's out whats going wrong over time.

Your answer


Register or to post your answer.