It's all about the answers!

Ask a question

Web Interface issue while using Enumerations

Roopin Shah (155) | asked Apr 18 '13, 6:21 a.m.

I have created fields that use Enumerations, this is being used in a custom tab, enumeration field values are visible when I use the Eclipse client, but the values do not appear when I use the web interface, I tried IE as well as Mozilla FireFox.

Does anybody have a work around for this? Or a cause for the issue?

2 answers

permanent link
Lauren Hayward Schaefer (3.3k11527) | answered Apr 18 '13, 6:48 a.m.

I did a quick search around and found the following forum topics that might provide solutions:

If those don't work for you, can you reply with the version you are using?  Does moving the enumeration to a non-custom tab make a difference?

Roopin Shah commented Apr 19 '13, 12:17 a.m.


The fields used for enumerations look fine when I raise a defect from Eclipse, but I can not see enumerations populate when I try the same using Web UI.

There are 2 sections in the tab, one alinged to the left hand side and the other to the right, one on the right does not list the enumeration values, but one on the left does, so I tried moving both the sections to the left hand side and it worked.

Not sure why it would not work when I aligned the section to right hand side.

I used version to create the new Work Item type.

Don Yang commented Apr 19 '13, 1:12 a.m.

if custom attribute layout is used, it has some problem in 3.0.1x for slot mappings. See the technote:

I see similar problem when set slot to left it does not work in Web client in 301.x but set slot to right works. No problem in 4.x though.

permanent link
Scott Sherwood (5624) | answered Apr 19 '13, 8:02 a.m.
Did you try clearing the cache on your web browser?  We make a lot of changes to our enumerated values.  When we see this behavior, we clean out the browser local cache, open a different project area, then come back to the PA where we want to see the changes.  They always show up then.

Roopin Shah commented Apr 22 '13, 12:42 a.m.

Yes I tried that, I also tried opening the PA from a different browser, but it did not help, unless I moved that section the left, it now works fine when I moved it to left hand side,

This can be a bug in 3.0.1.x I suppose, as mentioned by Don Yang.

Your answer

Register or to post your answer.