It's all about the answers!

Ask a question

RTC cannot handle dynamic data sources in RRDG reports?


ankur sharma (66212228) | asked Mar 29 '13, 8:15 a.m.
JAZZ DEVELOPER
 Why the dynamic data sources are not working for an RRDG report when deployed on RTC?

One answer



permanent link
ankur sharma (66212228) | answered Mar 29 '13, 8:18 a.m.
JAZZ DEVELOPER
 This is perhaps due to a known problem Cannot handle dynamic data sources in RRDG reports (252251). However, there are a couple of different workarounds for this problem.  

One is to hard code the user name/password into the template.

Another would be to rewrite the template so that it does not use dynamic data sources, but this is obviously not possible in all cases.

Or more manageable would be to 
-Add a new data source schema to the report template.  This data source is just a dummy, or placeholder - your report doesn't need to refer to it otherwise.  Make sure that the data source name does not start with an underscore.
-When you run the report in RTC, this dummy data source will show up as a parameter that needs to be configured.  Set the value of the parameter to an URL that corresponds to your dynamic data source.  For example, "<server-url>/ccm/rpt/respository/workitem" (it doesn't need to be more precise than that). 

Your answer


Register or to post your answer.