It's all about the answers!

Ask a question

Problem extracting Process Template in RTC


Tom Batting (757) | asked Mar 25 '13, 8:56 a.m.
retagged May 25 '13, 4:18 p.m. by Scott Rich (56136)
I am running RTC 4.0.

I have just started a new project in RTC. I have used the process template from a previous project that I extracted. This is all being run on the same server. 

The previous project was based on the out of the box 'Formal Project Management Process' template and then customised on top of that.  The template that i extracted across has only brought the custom additions that I made and not all the out-of-the-box attributes that were there. For instance my Defect work item only has 3 attributes listed (the ones that i created) and not the standard ones that were in my previous template.  This obviously has a massive effect on the presentations and enumerations etc and so I would like to know how to resolve this. Thanks.

Comments
Ralph Schoon commented Mar 25 '13, 9:04 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

You might want to add more information e.g. which version you are running and if you try to use the template on the same server.


Tom Batting commented Mar 25 '13, 9:06 a.m.

Thanks Ralph, I have changed my post! 


Jared Burns commented Mar 25 '13, 6:31 p.m. | edited Mar 25 '13, 6:33 p.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

Tom, there's nothing you can do which should cause the behavior you've described. Can you please report this problem to support? The things that would particularly help to debug this would be the exported process template and the Runtime Report from your original project area (which you can export from the Team Organization view by right clicking on the project and choosing "Generate Runtime Report"). If you are able to share this info with support or in a jazz.net defect, we can try to get to the bottom of it.

Accepted answer


permanent link
Piotr Aniola (3.6k1534) | answered Mar 25 '13, 10:01 a.m.
Your process template appears to  be corrupted. You may want to go through your initialization actions to see if everything is set correctly, or revert to an earlier, non-corrupted version of the template.

Alternatively, you may open a PMR against RTC, please note there is only a limited support for customizations.
Tom Batting selected this answer as the correct answer

One other answer



permanent link
Piotr Aniola (3.6k1534) | answered Mar 25 '13, 9:33 a.m.
Hello,

do I understand correctly that you created a fresh project based on the exported template, and only the custom additions are seen? Does the new project initialize correctly? Can you share the template?


Comments
Tom Batting commented Mar 25 '13, 9:39 a.m.

Hello Piotr,


You understand totally correctly. Funny you say that about initialize. I have just tried to initialize and it will not let me. It says a few attributes are not set and there is an exception running followup action. Please help!!

Your answer


Register or to post your answer.