It's all about the answers!

Ask a question

How can can one adjust the timeout for a Web or Eclipse session using WAS?


1
1
Stephane Couillaud (15631940) | asked Mar 06 '13, 7:41 p.m.
 I want to adjust the time out session for Web or Eclipse sessions? I see lots of questions but not necessarily the right answers for WAS. The closest I could find was these links but they apply to Tomcat not WAS:


Our sessions seem to expire after about 1 hr.  If I expand the CCM war file and look at the web.xml file I see the following:

<!-- set session timeouts to occur after 6 hours -->
<session-config>
<session-timeout>360</session-timeout>
</session-config>

Which seems to indicate my sessions should expire after 6 hrs not 1 hr like we've been observing.  Am I looking into the wrong place?  Any suggestions?


Comments
Kevin Ramer commented Mar 08 '13, 3:09 p.m.

Is the need to login to your application(s) after some time driving this expedition ?  The CLM license lease duration seems to be the driving force ( or at least influences it )


Kevin Ramer commented Mar 08 '13, 3:28 p.m. | edited Mar 08 '13, 3:28 p.m.

I just looked @ my WAS console.  There are session settings at these locations:

  • Application Server ( 240 min )
  • Within Enterprise Applications admin_war; qm_war; ccm_war; rm_war ; jts_war (infinite)
This bugs me as well as I've 1 group says they're forced to login more often.  I adjusted license check out time to 3h from the default of 2h.


Michael Prentice commented Mar 19 '13, 10:15 a.m.

I need to know the answer to this question ASAP as well. Numerous members of my team are demanding that the timeout be increased. We've tried making many changes to WAS to lengthen the timeout but none have had any effect. Now this issue has been escalated and requires immediate resolution for management.

One answer



permanent link
Bo Chulindra (1.3k2718) | answered Mar 19 '13, 10:55 a.m.
JAZZ DEVELOPER
Have you tried changing the LTPA token timeout? See here for information on how to change it.

Also see WAS LTPA token times out and requires re-authentication (115217) for a discussion on the issue of users being forced to re-authenticate every 2 hours. A summary of the discussion is that the LTPA token timeout on WAS is set to 2 hours by default and the timeout is not affected by user activity (so a user can be active for 2 hours and still be forced to re-authenticate). This is how LTPA tokens are designed to work.

Comments
Michael Prentice commented Mar 19 '13, 11:32 a.m.

Thank you. We're giving this a shot now. I'm restarting the entire server to try to make sure that the settings take effect. RTC installation should guarantee that the LTPA timeout is set to something higher than 120. Ideally, it should be set to something higher than 360 (which is what the web.xml files default to).


New installations should not need to deal with this WAS issue.


1
Michael Prentice commented Mar 19 '13, 3:22 p.m. | edited Mar 19 '13, 3:23 p.m.

We set the LTPA timeout to 2880 (48 hours) in the hopes that the other activity based tokens would take effect and this LTPA timeout would not cause us anymore headaches. So far after rebooting the server, it does appear to be taking effect and working as desired.


As mentioned in the work item, I think that updating the documentation for installing into WAS would be extremely helpful. This is not something that new installations who follow the documentation should need to figure out after install on the forums (see the numerous questions about the same thing).

Stephane Couillaud please accept this answer. Thank you Bo!

Your answer


Register or to post your answer.