It's all about the answers!

Ask a question

Updating the Custom Attributes when importing test cases from excel using Excel importer utility


Shashank Bellary (46167) | asked Feb 15 '13, 4:22 a.m.
retagged Feb 15 '13, 3:34 p.m. by Laura W. Hinson (16126)
 Hi,

We recently migrated to RQM 4.0.01 and I am using excel importer utility to export the test cases from Excel to RQM Repository. Before 4.0.* Custom Attributes were not supported to be exported using excel but I came to know that it is supported after 4.0.* but it is not working for me.

Below is my config file content

testscript.XLSStartRow=6

testscript.XLSArtifactID=B
testscript.dc:title=B
testscript.dc:description=C

testscript.steps.type="execution"
testscript.steps.description=E
testscript.steps.title=D
testscript.steps.name=D
testscript.steps.expectedResult=F

testscript.XLSDelimeter=\n
testcase.ID=testscript.XLSArtifactID

testcase.dc:title=testscript.dc:title
testcase.alm:state="Approved"

testcase.weight=I
testcase.category term="TestType".value="Functional"
testcase.category term="TemplateFolder".value="FeatureSpecific"
testcase.category term="Test Phase".value="Functional Test"
testcase.category term="Feature".value=K
testcase.category term="SubFeature".value=L

testcase.customAttributes identifier="User_Story_".name="User Story#".type="INTEGER".value="12345"

testcase.Section("myns:com.ibm.rqm.planning.editor.section.testCaseDesign","RQM-KEY-TC-DESIGN-TITLE")=C

testplan.identifier="urn:com.ibm.rqm:testplan:1428"
testplan.XSLLink=testcase

executionworkitem.XLSStartRow=1

executionworkitem.XLSLink=testscript
executionworkitem.dc:title=testcase.dc:title 
executionworkitem.dc:description=testscript.dc:description
executionworkitem.category term="TrackedUnder".value=C3
executionworkitem.category term="PlannedFor".value=C1
executionworkitem.category term="MileStone".value=C2


I am trying to export a test case which has test script and an Test Execution Record. 
Test Case has Custom Attributes ( Marked in Bold ) in the above config file content.

It is not getting updated.

I am also trying to link the newly created test case to an existing test plan . That is also not getting linked.

Please have a look and let me know what is wrong in the config file.

Thanks,
_Shashank



5 answers



permanent link
Laura W. Hinson (16126) | answered Feb 15 '13, 3:34 p.m.
JAZZ DEVELOPER
Hi Shashank,

The version 4.0.1 information center contains several topics about exporting test artifacts into the QM application. See http://pic.dhe.ibm.com/infocenter/clmhelp/v4r0m1/topic/com.ibm.rational.test.qm.doc/topics/c_import_word_excel.html and the topics within that section.

In particular, the topics about creating configuration files might be helpful.

permanent link
Hao Wan (1.5k35) | answered Feb 20 '13, 2:29 a.m.
JAZZ DEVELOPER
Hi Shashank, the format of specifying the id is
testplan.XLSArtifactId="urn:com.ibm.rqm:testplan:1428"
not
testplan.identifier="urn:com.ibm.rqm:testplan:1428"
you can change you config file and exporting again.

Comments
Shashank Bellary commented Feb 20 '13, 5:06 a.m.

It did not work, Please see the error in the below answer 


permanent link
Shashank Bellary (46167) | answered Feb 20 '13, 5:05 a.m.
 Hello Hao Wan,

Thanks for the reply, yes I did try this. It did not work. 

Getting this error after adding that line,

02/20/2013 3:26:25 PM: sending testplan3 named sampletest_1_1.xml
02/20/2013 3:26:27 PM: Server returned code InternalServerError
02/20/2013 3:26:27 PM: Error sending to server sampletest_1_1.xml of type testplan
02/20/2013 3:26:27 PM: Internal Server Error
02/20/2013 3:26:27 PM: sending testplan4 named sampletest_1_2.xml
02/20/2013 3:26:29 PM: Server returned code InternalServerError
02/20/2013 3:26:29 PM: Error sending to server sampletest_1_2.xml of type testplan
02/20/2013 3:26:29 PM: Internal Server Error
02/20/2013 3:26:29 PM: sending testplan5 named sampletest_1_3.xml
02/20/2013 3:26:31 PM: Server returned code InternalServerError
02/20/2013 3:26:31 PM: Error sending to server sampletest_1_3.xml of type testplan
02/20/2013 3:26:31 PM: Internal Server Error
02/20/2013 3:26:31 PM: sending testplan6 named sampletest_1_4.xml
02/20/2013 3:26:33 PM: Server returned code InternalServerError
02/20/2013 3:26:33 PM: Error sending to server sampletest_1_4.xml of type testplan
02/20/2013 3:26:33 PM: Internal Server Error
02/20/2013 3:26:33 PM: sending testplan7 named sampletest_1_5.xml
02/20/2013 3:26:36 PM: Server returned code InternalServerError
02/20/2013 3:26:36 PM: Error sending to server sampletest_1_5.xml of type testplan
02/20/2013 3:26:36 PM: Internal Server Error
02/20/2013 3:26:36 PM: sending testplan8 named sampletest_1_6.xml
02/20/2013 3:26:39 PM: Server returned code InternalServerError
02/20/2013 3:26:39 PM: Error sending to server sampletest_1_6.xml of type testplan
02/20/2013 3:26:39 PM: Internal Server Error
02/20/2013 3:26:39 PM: sending testplan9 named sampletest_1_7.xml
02/20/2013 3:26:41 PM: Server returned code InternalServerError
02/20/2013 3:26:41 PM: Error sending to server sampletest_1_7.xml of type testplan
02/20/2013 3:26:41 PM: Internal Server Error
02/20/2013 3:26:41 PM: sending testplan10 named sampletest_1_8.xml
02/20/2013 3:26:43 PM: Server returned code InternalServerError
02/20/2013 3:26:43 PM: Error sending to server sampletest_1_8.xml of type testplan
02/20/2013 3:26:43 PM: Internal Server Error

And it is sending test plan for each line in the sheet. How do I make it once per sheet ?

_Shashank 

permanent link
Shashank Bellary (46167) | answered Feb 20 '13, 5:58 a.m.
 I got the Custom attributes working,

My config file has the below lines now,

testcase.customAttributes.identifier="My_Custom_Attribute"
testcase.customAttributes.name="My Custom Attribute"
testcase.customAttributes.type="INTEGER"
testcase.customAttributes.value="12345"

Linking to Test Plan still did not work :(


permanent link
Hao Wan (1.5k35) | answered Feb 21 '13, 2:09 a.m.
JAZZ DEVELOPER
Hi Shashank,
the syntax
testcase.customAttributes identifier="User_Story_".name="User Story#".type="INTEGER".value="12345"
is for Excel Importer 4.0.1 or later version FYI.

Comments
1
Diane Everitt commented Feb 13 '14, 4:16 p.m.

Please use the latest version of the RQMExcelUtility for updating custom category values.  During recent testing, version 4.0.2 did not update the custom category values, however, version 4.0.5 did update them successfully.

Diane

Your answer


Register or to post your answer.