It's all about the answers!

Ask a question

Wrong status of a task in the Taskboard view


Ashwath G (6623449) | asked Feb 13 '13, 5:36 a.m.

Hello,

We are facing as issue in the task board view with wrong Task status.

When the users are moving the completed task from progress to the done status in the task board view , the task is going to invalid state.

But when they open the individual task and then change status to done it is showing properly.

I have rechecked the view options and workflow of task ,evrey thing is fine.

I dont know where thing is misfiring.

Please give me an idea to fix this

Ashwath

2 answers



permanent link
Guido Schneider (3.4k1486115) | answered Feb 13 '13, 5:55 a.m.

We had a similar issue a year ago. What we learned was:

When you move a task you move them into the state group and not into a state. The task is then set into the state with the lowest internal id.

This internal id is set by creation order of the states.

Because the Invalid state in the task was created before the done state it has a lower internal id and is selected when you move the task into the closed group

You have to recreate the Invalid state in the Task Workflow, so it get's a new number and then delete the old Invalid state. Of course you have also to move all existing WI's already in the current Invalid state before you can do this.


Comments
Ashwath G commented Feb 18 '13, 7:15 a.m.

This solution is working fine but all the Workitems with Previous inavlid status has unknown status after the new Invalid state created.I havre tried to change the status of these before deleting the previous Invalid state.

Either i could not see them in invalid state or i could not assign the state.

Its showing the state com.ibm.team.taskworkflow..in the status field of the WI.

Is there any workaround to fix this.

Thank you

Ashwath


Erwin Kunz commented Feb 18 '13, 8:11 a.m.

Hi Ashwath

You should have defined a special action to move from old invalid to new invalis .
Anyway.

I did it long ago and I'm not sure anymore. I think I worked in the eclipse and was able to modify all and after save they had the state new. And then I moved them to the new invalid

hope this helps


permanent link
Madhan Babu (368) | answered Jun 27 '13, 6:00 a.m.
Hi,

I'm also facing the same issue.
I have created a defect in Jazz.net for the same.
Link to the work item: Defect 270946

Your answer


Register or to post your answer.