It's all about the answers!

Ask a question

The RTC 2.0 version for Rational Asset Manager 7.5 does not start

Sunil Soans (1111) | asked Feb 04 '13, 8:44 a.m.
The RTC 2.0 version for Rational Asset Manager 7.5 does not start with the tomcat of RTC throwing the following error.

Feb 4, 2013 6:07:27 PM org.apache.catalina.core.StandardServer await
SEVERE: StandardServer.await: create[9005]: Address already in use: NET_Bind

One answer

permanent link
Sunil Soans (1111) | answered Feb 04 '13, 8:50 a.m.
It appears the port number 9005, where tomcat is listening for SHUTDOWN signal, is already used by another process. This was odd behaviour, since the tomcat of RTC was working fine with the settings as is.

I changed the setting for Tomcat to use another port number( from 9005 to 9006) by editing %CATALINA_HOME%\conf\server.xml:

< Server port = "9006" shutdown = "SHUTDOWN" >

Gili Mendel commented Feb 04 '13, 11:07 a.m.

Note that changing the port of RTC will require updates to RAM's configuration (link to RTC).

On Linux, if you do not shutdown gracefully, a port would not be release (for some timeout) for security reason.... can't remember off line .. but you can override the length of this timeout.

... did you try to restart the machine?

Sunil Soans commented Feb 05 '13, 1:25 a.m.

This port number 9005 or 9006 is not the port on which the RTC tomcat will be running. This is the port on which the tomcat will listen for shutdown command. I believe the RAM's configuration will need to be changed only if the port on which RTC tomcat will run is changed.

My environment was windows

I did not restart the machine as it was a production server.

After changing the shutdown port number from 9005 to 9006, RTC tomcat started correctly.

After that RAM also worked fine without any errors.

Rich Kulp commented Feb 05 '13, 10:56 a.m.

That is simply telling us you already have another process running that is using 9005. That means that there is probably a Tomcat already running and you tried to start another instance of the same Tomcat.

Or as Gili mentioned, the original Tomcat shutdown hard and didn't release the ports immediately. And then you tried to bring the Tomcat back up and it now failed because the port was still in use.
Each Tomcat uses up a series of ports. Unless the server.xml configuration file is changed for that Tomcat the default ports are:

shutdown port: 8005
http port: 8080
https port: 8443
AJP connector: 8009

Sunil Soans commented Feb 06 '13, 1:32 a.m.

Thanks Richard. I had verified that tomcat was not running. Probably as mentioned tomcat may have shut down hard and the port was not released.

The default ports on the tomcat of RTC 2.0 used for the RAM 7.5 instance were
shutdown port: 9005
http port: 9080
https port: 9443
AJP connector: 9009

Of these I changed the shutdown port from 9005 to 9006 and I could start the RTC tomcat instance fine.

Thanks again for the detailed tomcat troubleshooting description.

Your answer

Register or to post your answer.

Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.