It's all about the answers!

Ask a question

What version of RSA and RAD are support by RTC 4.0.1


Thomas Loeber (62237950) | asked Jan 29 '13, 2:40 p.m.
JAZZ DEVELOPER
retagged Feb 01 '13, 2:06 p.m. by Stephanie Taylor (24115)
Our team uses a combination of RSA and RAD clients with RTC 3.0.1.5. We are planning an upgrade to 4.0.1 and will want to upgrade our clients as well. What versions of RSA and RAD are supported by the 4.0.1 RTC client extension?

5 answers



permanent link
Lara Ziosi (33811112) | answered Feb 20 '13, 9:55 a.m.
Hi Michael,

The integration of RTC 4.0.1 is officially supported with RSA 8.5 and 8.5.1. You should also note that for installing with RSA, you need to select the Extension Install package for Installation Manager (this is not the full-standalone client, it is meant specifically for installing on an existing Eclipse-based product).

RSA 8.0.4.2 is officially supported in integration with RTC 3.0.x.

(note that RSA 8.5 is not an upgrade of RSA 8.0.42, it is a full new installation).

Would that be an option you could try?

Thank you and regards, Lara



Comments
JL Marechaux commented Feb 20 '13, 10:00 a.m. | edited Feb 20 '13, 10:01 a.m.
JAZZ DEVELOPER

Michael,


Note that Lara is from IBM Customer Support, so she provides the "official" support answer.
As I was saying in my first post, you may have some configurations that "work" but are not "supported" when you run into a problem. 

Lara,  is there any IBM Support URL you could share with use where the supported versions are listed?


permanent link
Lara Ziosi (33811112) | answered Oct 22 '13, 4:02 a.m.
Hello Fracisco,

RAD 6.0 has been out of support for many years. It was based on Eclipse 3.2. RTC 4.0.1 supports Eclipse 3.6, so ,my guess is that it will not work.
The supported versions of RAD are 7.5, 8.0, 8.5 and 9.
From this page you can figure out the compatibility matrix:
http://publib.boulder.ibm.com/infocenter/prodguid/v1r0/clarity/softwareReqsForProduct.html
Prerequisites > Propduct/Prerequisite Combination
From there, you can see that RTC 4.0.1 is compatible with RAD 8.5, 8.5.1 and 8.5.5

Thank you, Lara

permanent link
JL Marechaux (199611) | answered Jan 29 '13, 3:39 p.m.
JAZZ DEVELOPER
 RTC 4.0.1 should work with RAD/RSA 8.0.2 (and higher), 8.5, and 8.5.1 as it requires Eclipse 3.6.2 or 3.7.2
From an "official" support perspective, I am not sure if 8.0.2 is supported

Comments
Thomas Loeber commented Jan 31 '13, 8:45 a.m.
JAZZ DEVELOPER

Thanks Jean-Louis.  I wasn't aware of RAD/RSA 8.0.2.  We are currently using RSA/RAD 8.0.4.2. Is this documented somewhere?


JL Marechaux commented Jan 31 '13, 9:12 a.m.
JAZZ DEVELOPER

http://www-01.ibm.com/support/docview.wss?uid=swg27019500#Integrations.

But remember that I have never tested the integration with 8.0.2 or 8.0.4 myself. and for some reason, only v8.5 is listed here https://jazz.net/library/article/811/#mozTocId712617


permanent link
Michael Müller (1112) | answered Feb 20 '13, 8:39 a.m.
Hi Jean-Lous,
we have problems with the installation of  RSA 8.0.4.2 in combination with RTC 4.0.1.
RSA 8.0.4.1 with RTC 4.0.1 can be installed.
RSA 8.0.4.2 with RTC 4.0.0.1 can be installed.
RSA 8.0.4.2 with RTC 4.0.1 cannot be installed, getting this error in the installation manager log file:

!SESSION 2013-02-18 13:00:33.985 -----------------------------------------------
eclipse.buildId=unknown
java.fullversion=JRE 1.6.0 IBM J9 2.4 Windows 7 x86-32 jvmwi3260sr11-20120801_118201 (JIT enabled, AOT enabled)
J9VM - 20120801_118201
JIT  - r9_20120608_24176ifx1
GC   - 20120516_AA
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=de_DE
Framework arguments:  -application org.eclipse.equinox.p2.reconciler.application -product org.eclipse.equinox.p2.reconciler.dropins.product
Command-line arguments:  -os win32 -ws win32 -arch x86 -application org.eclipse.equinox.p2.reconciler.application -product org.eclipse.equinox.p2.reconciler.dropins.product
!ENTRY org.eclipse.equinox.registry 2 0 2013-02-18 13:00:41.031
!MESSAGE The extensions and extension-points from the bundle "com.ibm.datatools.informix.driver" are ignored. The bundle is not marked as singleton. 
!ENTRY org.eclipse.equinox.registry 2 0 2013-02-18 13:00:43.517
!MESSAGE The extensions and extension-points from the bundle "org.eclipse.emf.commonj.sdo" are ignored. The bundle is not marked as singleton. 
!ENTRY org.eclipse.equinox.p2.engine 4 4 2013-02-18 13:01:27.959
!MESSAGE An error occurred while installing the items
!SUBENTRY 1 org.eclipse.equinox.p2.engine 4 0 2013-02-18 13:01:27.959
!MESSAGE session context was:(profile=bootProfile, phase=org.eclipse.equinox.internal.p2.engine.phases.Install, operand=null --> [R]org.eclipse.equinox.p2.garbagecollector 1.0.100.v20100503, action=org.eclipse.equinox.internal.p2.touchpoint.eclipse.actions.InstallBundleAction).
!SUBENTRY 1 org.eclipse.equinox.p2.touchpoint.eclipse 4 0 2013-02-18 13:01:27.959
!MESSAGE The artifact file for osgi.bundle,org.eclipse.equinox.p2.garbagecollector,1.0.100.v20100503 was not found.

Comments
Thomas Loeber commented Feb 20 '13, 9:01 a.m.
JAZZ DEVELOPER

I have successfully installed RTC 4.0.1 with RAD 8.0.4.2, but haven't done so with RSA 8.0.4.2.   We have also successfully installed RTC 4.0.1 with RAD 8.5.1 but have tried it with RSA 8.5.1.
Have you opened a defect for this RSA issue?


JL Marechaux commented Feb 20 '13, 9:27 a.m. | edited Feb 20 '13, 9:27 a.m.
JAZZ DEVELOPER

Hi Michael,


I am trying to have someone from Customer Support provide an "official" answer regarding the different versions supported. Stay tuned...


permanent link
Francisco Rodriguez (561428) | answered Oct 21 '13, 7:47 p.m.
 Hi everyone,

Is it possible for RTC 4.0.1 to work with RAD 6.0.0?

Regards.

Francisco Jose Rodriguez Garcia
Software Configuration Management
Iusacell

Your answer


Register or to post your answer.


Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.