It's all about the answers!

Ask a question

RTC Eclipse client install fail


Neil Russell (1311) | asked Jan 04 '13, 4:03 p.m.
 Hi,

I tried to install 4.0.1 RTC client onto Indigo on CentOS5.7, it failed with a dependency problem.

CRIMA1056E: Offering cannot be installed into this existing Eclipse installation configuration because it would invalidate existing bundle constraints

  CRIMA1054E: Installing bundle "org.eclipse.xsd_2.6.0.v20100914-1218" into this existing Eclipse installation does not meet the version tolerance of "[2.7.0,3.0.0)" for the existing bundle "org.eclipse.xsd.edit"


So - I figured I needed an older version of the RTC Eclipse client, so I downloaded the 3.1.05 version.

But now I run launchpad.sh, and during the prompts, some class not found:

org.eclipse.core.runtime.CoreException: Plug-in com.ibm.cic.agent.core.eclipseInstallAdaptor was unable to load class com.ibm.cic.agent.internal.installAdaptors.EclipseInstallAdaptor.


Thanks,

--N


Accepted answer


permanent link
Ralph Schoon (60.9k33643) | answered Jan 09 '13, 8:55 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
Here the system requirements https://www.jazz.net/library/article/1109 . Your OS seems not to be supported. But even then, it often works. Have you tried to use the p2 install?
Neil Russell selected this answer as the correct answer

Comments
Neil Russell commented Jan 09 '13, 9:47 a.m.

Doing the standalone "p2" install lays down the files needed. By carefully selecting the "ibm" components from there, it seems to work.

Your answer


Register or to post your answer.