It's all about the answers!

Ask a question

Roadmap in Sprint Plan disappears after adding Tasks


Horst Hartmann (1111) | asked Jan 02 '13, 10:20 a.m.
I have a similar question asked in https://jazz.net/forum/questions/82737/using-roadmap-to-view-sprint-plan-but-the-gantt-chart-shows-nothing , but recommended solution does not solve my problem.
Web-UI of RTC 3.0.1.2 is used.

I've created a Release Backlog Plan  and Sprint Plans with Epics and Stories. All can be seen in the Roadmap view and give a nice overview. As soon as I add Tasks, the parent Story and Epic is not displayed in the Roadmap view anymore, e.g:
Epic spans Sprint1 and Sprint2. Sprint1 has Story1 and Sprint2 has Story2 defined. I see a long bar for the Epic spanning Sprint1/2 and underneath 1 Bar for Story1 in Sprint1 and another Bar for Story2 in Sprint2.
When I add Tasks to Story 1 the Bars in Sprint1 disappears for the Epic and Story1. Bars in Sprint2 are still visible, Epic and Story2.

Categories and Plans are all are assigned/owned to/by the same team and people are all part of that team.
What am I doing wrong ?

Accepted answer


permanent link
Millard Ellingsworth (2.5k12431) | answered Jan 03 '13, 6:55 p.m.
FORUM ADMINISTRATOR / JAZZ DEVELOPER
Hi, Horst.

I've tried this with a 4.0.1 server and my initial impression is "it's all fun and games until there's a concrete assignment". Like you, I had nice, long bars spanning two sprints for the epic and the sprint for the story. Then I added a task and the bars disappeared. Then I assigned the task and gave it an estimate -- and the bars came back, though the story bar now brackets only the task bar.

I expect the scheduler, without real tasks and timeframes, simply calculates the bar to be the length of the sprint(s) -- what else can it do? But as soon as you give it real information about durations and assignments it's able to adjust and calculate something meaningful (which will at first be much shorter in length until you get the full schedule built up).

Can you give that a try and see if it behaves as you'd expect? If you are still seeing issues, I'll find a 3.0.1 server and repeat my experiment.
Millard Ellingsworth selected this answer as the correct answer

Comments
Horst Hartmann commented Jan 07 '13, 4:42 a.m.

Millard,
thanx for the response.

All the tasks have estimates. The bar for the Story disappeared completeky and the bar for the Epic is shortened by the forst Sprint. Moving the mouse over the Epic bar shows the correct complete duration, Sprint1 and Sprint2.

Is there a chance that this problem is related only to Version 3.01 and will be fixed with 4.0.1 ?


Millard Ellingsworth commented Jan 07 '13, 12:03 p.m.
FORUM ADMINISTRATOR / JAZZ DEVELOPER

Firstly, do the tasks have owners as well as estimates?


The behavior I see in 4.0.1 seems to be appropriate, so assuming we're talking about the same thing, it appears to behave correctly. I'll also track down a 3.0.1 server to see what differences there may be in the behavior.


Millard Ellingsworth commented Jan 07 '13, 1:52 p.m.
FORUM ADMINISTRATOR / JAZZ DEVELOPER

It looks like this is behavior that improves in 4.0.1. On a 3.0.1.4 server, I also see the bar for Sprint 1 simply go away after adding a task. Assigning the task, giving it an estimate, saving everything and refreshing the plan does not bring it back.


Horst Hartmann commented Jan 08 '13, 4:05 a.m.

Millard,
I will upgrade to 4.0.1 asap and give feedback here. However, it'll take some time.
Thanx for your help.


Horst Hartmann commented Jan 22 '13, 10:57 a.m.

Millard,
we've RTC 4.0.1 up and running. Problem is still the same. The tasks in question have estimates and owners, the plan (sprint), category and owner belong to the same team. As soon as tasks are estimated the parent story disappears. The epic bar shows up only for stories without tasks.
Is it possible that some of the regular running batch jobs are missing ?


Millard Ellingsworth commented Jan 22 '13, 11:42 a.m.
FORUM ADMINISTRATOR / JAZZ DEVELOPER

Hi, Horst. Sorry to hear that you are still having issues with this. Have you modified the process template? If so, is it reasonable for you to share it?


In my previous follow-up I was using a out-of-the-box scrum template and while the bar changed size once tasks were added (making it much smaller to match the tasks' duration) it didn't disappear. Any chance the length of your iteration and the size of your estimates just causes the bar to be "drawn" so small it disappears? If you zoom in on the roadmap is it still missing? Sorry to be grasping at straws but I don't see what you see using the same version of the software.


Horst Hartmann commented Jan 29 '13, 11:21 a.m.

Millard, I've some good news. All of a sudden the bars are showing up as expected, actually 2 days after the upgrade. So 4.0.1 seems to be the solution. I can observe that there is a delay between creating and estimating task and the correct presentation in the roadmap view. Which delay is expected ? Any way to accelerate ?


Millard Ellingsworth commented Jan 29 '13, 11:47 a.m.
FORUM ADMINISTRATOR / JAZZ DEVELOPER

That's awesome that it is working now, thanks for following up.


As to the delay, I'm presuming it is related to your overall system performance. Each change is likely to cause a recalculation (which is done asynchronously). The more complicated the plan, the more burden on the server, the longer it takes.

That said, in my small test project, I did not notice a delay (though it was an optimal environment). How long of a delay are you seeing after making a change that would affect the schedule? 


Horst Hartmann commented Feb 08 '13, 3:39 a.m.

Millard,
sorry for the delayed update, I'm currently quite busy with planning related stuff..

To your question, it depends. Let me give an example: The EPIC usually shows the accumulated Story points of all children STORIES. When adding a story the accumulated story points did not show the correct value immediately.

I think your point about performance is the clue. The first days after the upgrade to 4.0.1 a lot of calculations showed wrong values. In he meantime this problem disappeared as well. Even better, most changes are now reflected almost immediately.

I cosider this issue as solved !!
Thanks again for your help.

showing 5 of 9 show 4 more comments

Your answer


Register or to post your answer.