It's all about the answers!

Ask a question

User can't login after backup script


Matus Gura (1726) | asked Dec 12 '12, 9:58 a.m.
retagged Dec 12 '12, 11:19 a.m. by Bo Chulindra (1.3k2718)
Hi,
we have JazzTeamServer 4.0 (RTC,RQM,RRC(all 4.0)), recently upgraded from 3.0.1.2
If we reset password to our user, he can't login next day (during night, there is backup script). We don't use LDAP, user data are stored in tomcat-users.xml.
The only similiar error in logs is: (in jazz.log)
2012-12-11 03:01:36,187 [jazz: AsynchronousTaskRunner-3] ERROR com.ibm.team.repository - CRJAZ2388E Error encountered when synchronizing user data between servers in the background.  The synchronizer will silently continue to attempt to synchronize the data.
Any ideas?
----
EDIT:
Backup script "timeline" (suspend indexer, stop server, do backup, start server, resume indexer)
(after backup script, there is still running old java process although ./server.shutdown was called)
----

Thanks

Comments
Karl Weinert commented Dec 12 '12, 10:52 a.m.
JAZZ DEVELOPER

How do you resolve the issue?
What database are you using and is that being stopped during the backup as well?
If so make sure it gets restarted before RTC
How are you resetting the password?


Matus Gura commented Dec 12 '12, 4:26 p.m.

 We are using IBM DB2. Yes, it's being restarted during backup, when JTS is turned off. We are reseting using web UI (we tried also Eclipse client). I tried @bkchulin idea, I am waiting for colleagues feedback

Accepted answer


permanent link
Bo Chulindra (1.3k2718) | answered Dec 12 '12, 11:16 a.m.
JAZZ DEVELOPER
Matus Gura selected this answer as the correct answer

Comments
Matus Gura commented Dec 14 '12, 5:58 a.m.

 Thanks! 

Your answer


Register or to post your answer.