It's all about the answers!

Ask a question

4.0.1 Diagnostic Error: Quality Management cannot be accessed


Mike Shkolnik (9657147143) | asked Dec 07 '12, 7:12 p.m.
Diagnostics ran fine when i first finished the upgrade from 2.x to 3.x to 4.01. I tried a shutdown and restart but that did not clear up the error. The error:

Friend: the discovery resource at https://rtc.devtst.go2uti.com:9443/qm/rootservices for "Quality Management (/qm)" cannot be accessed:
The returned HTTP status was 404
The response body was

HTTP Status 404 - ProxyServlet: /qm/rootservices


type Status report

message ProxyServlet: /qm/rootservices

description The requested resource (ProxyServlet: /qm/rootservices) is not available.


Apache Tomcat/7.0.25

Accepted answer


permanent link
Ralph Schoon (55.4k23642) | answered Dec 09 '12, 5:47 p.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
edited Dec 09 '12, 5:48 p.m.
Mike, 404 indicates there is an issue with deployment of QM. I have once seen that on Tomcat the uncompress of the war file did not work. I deleted the folder Server/Tomcat/webapps/qm and started again. That solved the issue. I would also suggest to thoroughly look into the log files. I would in addition expect the diagnostics page in the JTS administration to show an error with the registered QM application. I can't believe the QM application was there and then vanished.

Please check the logs (application and tomcat logs), if there is anything suspicious.
 
Last thing thing you could try is to delete \server\tomcat\work\Catalina\localhost\qm. I have heard that the data there sometimes gets confused and deletion helps. I have however not tried that myself yet.
Mike Shkolnik selected this answer as the correct answer

Comments
Mike Shkolnik commented Dec 10 '12, 3:21 p.m.

Reinstalling did not fix the problem. However, it appears your second suggestion of removing (or renaming) \server\tomcat\work\Catalina\localhost\qm has worked, at least for now. Diagnostics now succeed and I can get to the qm status screen. Thanks much. 


Ralph Schoon commented Dec 11 '12, 8:11 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

Mike, I fail to understand why reinstall would not include creating a new Tomcat/work folder. If you did and had to delete the work folder anyway, this is certainly a defect I would file. If you would reinstall, see the same error, delete the work folder(s) and not see it, that would be a more logical workflow.

Your answer


Register or to post your answer.