It's all about the answers!

Ask a question

Why does "repotools-ccm.bat -rebuildIndices" fail with "CRJAZ0811I Failed to detect whether the "package to schema" map exists."


Guido Schneider (3.4k1383110) | asked Nov 30 '12, 4:06 a.m.

I run the repotool command to rebuild indices, because the fulltext search is not display all records it should.

But I got an error. (see below). Any Idea what I'm missing?

My environment:
CLM V.4.0.0.1/64bit
Windows 2008-R2/64bit
WAS 8.0.0.4/64bit
DB2 9.7.5/64bit

Here what I did:

C:\IBM\JazzTeamServer_4001\server>.\repotools-ccm.bat -rebuildIndices

Repo Tools
Provisioning using "C:\IBM\JazzTeamServer_4001\server\conf\ccm\provision_profiles".
  Jazz Foundation - Core Libraries, Version 4.0.0.1 (RJF-I20120906-1745)
  Change and Configuration Management - Core Libraries, Version 4.0.0.1 (RTC-I20120911-1740)
CRJAZ1363I Loading the configuration from "file:conf/ccm/teamserver.properties".
CRJAZ1778I This server is configured as an application.
CRJAZ1365I The server is attempting to connect to the following database: "//db1.clm.company.com:50000/CCM:user=xxxxxxxx;password=xxxxxxxx;"
CRJAZ1364I The connection to the following database was successful:
  Db Product Name: DB2/NT64
  Db Product Version: SQL09075
  Db URL: jdbc:db2://db1.clm.company.com:50000/CCM:user=xxxxxxxx;password=xxxxxxxx;
  Jdbc Driver Name: IBM DB2 JDBC Universal Driver Architecture
  Jdbc Driver Version: 3.57.82
CRJAZ1970I The application is configured with:
  Public URI: "https://clmserver01.company.com/ccm"
  Jazz Team Server location: "https://clmserver01.company.com/jts/"
Rebuilding the indices for the database "//db1.clm.company.com:50000/CCM:user=xxxxxxxx password=xxxxxxxx;".

java.sql.SQLException: CRJAZ0811I Failed to detect whether the "package to schema" map exists.
CRJAZ1217I Failed to rebuild the indices for the database "//db1.clm.company.com:50000/CCM:user=xxxxxxxx;password=xxxxxxxx;".


2 answers



permanent link
Ralph Schoon (60.5k33643) | answered Nov 30 '12, 6:26 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
Hi Guido, I would strongly recommend to open a PMR for this.

BTW, the command rebuilds the database indexes. That are, as far as I can tell, not the full text indexes. I belive that is for work items   -reindex --Recreate query and search indexes and    -rebuildTextIndices --Rebuild text indices.


Honestly I am not sure which is for what though.
 

permanent link
Guido Schneider (3.4k1383110) | answered Nov 30 '12, 9:12 a.m.
edited Nov 30 '12, 9:13 a.m.
 

I did more:

 

.\repotools-jts.bat -rebuildIndices
.\repotools-jts.bat -rebuildTextIndices
.\repotools-jts.bat -reindex

.\repotools-ccm.bat -rebuildIndices
.\repotools-ccm.bat -rebuildTextIndices
.\repotools-ccm.bat -reindex  

.\repotools-qm.bat -rebuildIndices
.\repotools-qm.bat -rebuildTextIndices
.\repotools-qm.bat -reindex

https://jazz.net/forum/questions/52053/triple-index-and-text-index-reindex

 

Maybe it was to much, just for the Fulltextsearch? The problem we had was the quick search as well as the search by adding links to workitems was not showing all matches.

 I will open a PMR

(is number six this week, after upgrade from 3.01.4 to 4.0.0.1, Jazz is a very social tool. It saves a lot of IT jobs worldwide.)


Comments
Ralph Schoon commented Nov 30 '12, 9:29 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

See, Jazz is good for you.

I had a case where the workitem index got confused too. I think I deleted it and ran one of the commands to get it back and that solved the issue. One reason why the indexes can get confused is when you have them on a network mounted disk that is shared by another machine.

Your answer


Register or to post your answer.