It's all about the answers!

Ask a question

RTC 4.0 on Ubuntu 12.04 blows up when trying to open history of a work item


Barys Dubauski (19148) | asked Nov 09 '12, 11:43 a.m.
JAZZ DEVELOPER
edited Sep 29 '14, 4:40 a.m. by Francesco Chiossi (5.7k1819)
On my 32-bit Ubuntu 12.04 LTS I have RTC 4.0 client (unpacked from a plain zip). It functioned normally until at some point I tried to click on a "History" tab. Then I get errors like below:

Error logged from Process Client UI: 
No more handles [MOZILLA_FIVE_HOME='/usr/lib/xulrunner-addons'] (java.lang.UnsatisfiedLinkError: Could not load SWT library. Reasons: 
/home/dubauski/dev/jazz/client/eclipse/configuration/org.eclipse.osgi/bundles/502/1/.cp/libswt-mozilla-gtk-3659.so (libxpcom.so: cannot open shared object file: No such file or directory)
swt-mozilla-gtk (Not found in java.library.path)
/tmp/swtlib-32/libswt-mozilla-gtk-3659.so (libxpcom.so: cannot open shared object file: No such file or directory)
/tmp/swtlib-32/libswt-mozilla-gtk.so (/tmp/swtlib-32/liblibswt-mozilla-gtk.so.so: cannot open shared object file: No such file or directory)
)
After this error I'm recommended to exit RTC workbench.

I have searched extensively on this issue and have tried to switch to a different xulrunner (1.9.0.17, 1.9.2.13, 1.9.2.19, 3.6.28, 16.0.2, etc) but to no success. At best I was getting different errors or RTC would simply crash.


Accepted answer


permanent link
Tim Mok (6.6k38) | answered Nov 09 '12, 12:09 p.m.
JAZZ DEVELOPER
I specify an installation of xulrunner to use with the instructions on the Eclipse SWT FAQ. I use the first option with the -D flag to set the xulrunner location.

Then I use one of the versions that is supported based on the Eclipse version I'm using as specified here.

For RTC 4.0, it is using Eclipse 3.6.2 and the 1.9.x versions of xulrunner should work. It seems to be looking in /usr/lib/xulrunner-addons for your xulrunner. Is this the correct location where you've installed xulrunner?
Barys Dubauski selected this answer as the correct answer

Comments
Barys Dubauski commented Nov 09 '12, 4:09 p.m. | edited Nov 09 '12, 4:28 p.m.
JAZZ DEVELOPER

Thank you Tim! The combination of -D flag option in eclipse.ini with xulrunner v.1.9.2.19 worked.


To those who has the same problem with RTC 4.0 on Ubuntu 12.04 and would like to know the exact steps here they are:

1. Install xulrunner v.1.9.2.19 by running script below (borrowed from askubuntu.com/questions/125980/how-do-i-install-xulrunner-in-12-04):

FFVER=1.9.2.19 ARCH=uname -p 

XURL=https://ftp.mozilla.org/pub/mozilla.org/xulrunner/releases/$FFVER/runtimes/xulrunner-$FFVER.en-US.linux-$ARCH.tar.bz2 

cd /opt 

sudo sh -c "wget -O- $XURL | tar -xj" 

sudo ln -s /opt/xulrunner/xulrunner /usr/bin/xulrunner 

sudo ln -s /opt/xulrunner/xpcshell /usr/bin/xpcshell

2. Modify RTC's eclipse.ini file by adding the following -vmargs parameter: 
-Dorg.eclipse.swt.browser.XULRunnerPath=/opt/xulrunner


Matthias Lee commented Dec 18 '12, 3:38 p.m.

Perfectly summed up. Thanks.


Massimiliano Celli commented Apr 21 '13, 4:22 a.m. | edited Apr 22 '13, 8:41 a.m.

That's great, it solved the problem I always had with my RTC (whatever version) Eclipse client on Ubuntu.
Thanks!


Markus Rummler commented Sep 11 '13, 1:57 a.m.

You made my day! Thank you!

One other answer



permanent link
Julian Ko (1) | answered Apr 16 '14, 9:36 p.m.
I recently installed RMC( method composer) and encountered the same problem. Following the steps lead to the xulrunner version that's too new and cause XCOMP error. It is recommend to keep using V1.9.2.x if you encounter some other problems.

Your answer


Register or to post your answer.