It's all about the answers!

Ask a question

RTC 3.0.1 plugin Migration to RTC 4.0


Kaushik Bhalerao (611810) | asked Oct 30 '12, 4:06 a.m.
edited Oct 30 '12, 5:35 a.m. by Ralph Schoon (60.5k33643)
Current Environment :
  • RTC 3.0.1Installed
  • Respective SDK used for Plugin Development
  • OS: win 7
  • Client : RTC eclipse 3.0.1
  1.  Currently We developed plugins for current environment.
  2. Now we are migrating RTC 3.0.1 to RTC 4.0
Q:Can we migrates plugins of rtc 3.0.1 to rtc 4.0 ?

Q:What is Good Way for it?

(Please feel free to ask any other required information about this question if needed.)



2 answers



permanent link
Kaushik Bhalerao (611810) | answered Oct 30 '12, 7:31 a.m.
I know that ,Its possible to migrate project area.from RTC 3.0.1 to 4.0 .But I am more interested in
"Is it possible to migrate RTC plugins (Pre condition ,Followup action and server side plugin ) from RTC 3.0.1 to RTC 4.0.?"


(Sorry For incorrect tagging )

Comments
Ralph Schoon commented Oct 30 '12, 8:12 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

As described in the other answer, I basically imported the 3.x plugin and other projects into an RTC 4.x client with the SDK set up. I had no issues with the code and you would basically just rebuild to deploy against 4.x.


permanent link
Ralph Schoon (60.5k33643) | answered Oct 30 '12, 5:34 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
As answered in the other two similar questions especially https://jazz.net/forum/questions/92466/can-we-integrate-rtc-301-api-with-rtc-40-api-so-that-we-can-develope-single-plugin-for-both

Please don't ask the same question over and over again, if you think you want to provide more content, comment on your original question or edit it.

As a side note, please consider your tagging. What is the relationship to Jazzhub or jazz.net?

Your answer


Register or to post your answer.