It's all about the answers!

Ask a question

Are provision profiles "ordered" during server provisioning ?


Kevin Ramer (4.5k6171190) | asked Oct 23 '12, 11:21 a.m.
Being asked to install the SCD plugin but it fails this way:
CRJAZ0303I The profile install from "file:jazz/sites/com.ibm.devops.build.cloud.updatesite" was started at "Mon Oct 22 19:33:33 EDT 2012".
CRJAZ0300I Installing the feature "com.ibm.devops.build.integration_feature_1.0.2.201210081514".
CRJAZ0281I The dependency bundle "com.ibm.team.repository.common" is not installed and no features available for installation provided that bundle.
CRJAZ0288I Failed to install the profile feature "com.ibm.devops.build.integration_feature" from the update site "file:jazz/sites/com.ibm.devops.build.cloud.updatesite" referenced in the profile file "/CLM.3/rtp-rtc9/server/conf/jazz/provision_profiles/com.ibm.devops.build.cloud.updatesite.ini".

However, well into the provision log (and after the above):

CRJAZ0300I Installing the feature "net.oauth.jfs.feature_1.0.1.v20110922_1848".
CRJAZ0275I The bundle "net.oauth" is already installed.

CRJAZ0300I Installing the feature "org.apache.commons.httpclient.jfs.feature_1.0.0.v20101110_2242".
CRJAZ0299I Installing bundle from the URL "file:/CLM.3/rtp-rtc9/server/conf/jazz/sites/update-site/plugins/org.apache.commons.httpclient_3.1.0.v20080605-1935.jar".

CRJAZ0299I Installing bundle from the URL "file:/CLM.3/rtp-rtc9/server/conf/jazz/sites/update-site/plugins/com.ibm.team.repository.common_1.3.100.v20120315_0042.jar".
CRJAZ0299I Installing bundle from the URL "file:/CLM.3/rtp-rtc9/server/conf/jazz/sites/update-site/plugins/com.ibm.team.repository.common.transport_1.1.1.v20110524_1821.jar".
CRJAZ0299I Installing bundle from the URL "file:/CLM.3/rtp-rtc9/server/conf/jazz/sites/update-site/plugins/com.ibm.team.repository.common.json_1.1.1.v20110524_1821.jar".
Can the provisioning order be changed by changing the name of the update site ?
RTC 3.0.1.3 server on AIX 6.1

Accepted answer


permanent link
Girish Pandit (16) | answered Oct 31 '12, 9:03 a.m.
JAZZ DEVELOPER
The dependency issue occurred because the CLM related bundles were not found when you tried to install the SCD plugin. Can you please try to install the CLM before installing the SCD plugin? 

As long as you use the same name (as of the update site in /server/conf/ccm/sites/ ) of update site in provision_profiles file I think it should be okay.
Kevin Ramer selected this answer as the correct answer

Comments
Kevin Ramer commented Oct 31 '12, 12:34 p.m.

Further along in the provision profiles we see that the cloud plug-ins get loaded and started.

Your answer


Register or to post your answer.