It's all about the answers!

Ask a question

RTC - top level files not visible in Project Explorer nor do they show up in Pending Changes when changed

Paul Callahan (20136) | asked Oct 11 '12, 10:42 p.m.
edited Oct 11 '12, 10:43 p.m.
 we had our maven project migrated from another source control system to RTC.

The structure looks like:

When the repository workspace is loaded, those 4 top level files for some reason need to get loaded manually or they never appear.  Also, even though they are loaded, they do not show up in the Project Explorer.  And if they're edited, they don't get detected as changed in the Pending Changes view (yes, I've refreshed the sandbox from inside the pending changes view).
It's like RTC is ignoring all top level files and only showing directories.

Does anyone know how to fix this?

Accepted answer

permanent link
Victor Campbell (3502618) | answered Oct 12 '12, 9:24 a.m.
When you load the workspace, do you select "Browse the components to select the folders to be loaded", and check the top level component root folder, and uncheck the folders that are selected by default?
Paul Callahan selected this answer as the correct answer

Paul Callahan commented Oct 12 '12, 3:03 p.m.

 this did the trick.  The top level component looked like it had a + next to it rather than a checkbox, so it wasn't clear to me that you could select that.  Thanks.

Your answer

Register or to post your answer.

Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.