It's all about the answers!

Ask a question

IllegalStateException: Inverse metadata missing for item [UUID _9j4B8JuqEeGRragUX4ocxg]

Sridhar Reddy (122) | asked Oct 10 '12, 6:49 a.m.
Hello, Has anybody seen this error while using the build system toolkit? The server is at and I have tried the toolkit versions through the latest v4. All seem to fail. I have also tried different repository workspaces on the server as well. My regular RTC client works alright but we use JAZZ ANT tasks in the build system toolkit for automation of source download and build. 

 [teamFetch] java.lang.IllegalStateException: Inverse metadata missing
for item [                                                              
UUID _9j4B8JuqEeGRragUX4ocxg]                                           
[teamFetch]     at             
[teamFetch]     at        

3 answers

permanent link
Lauren Hayward Schaefer (3.3k11427) | answered Oct 10 '12, 7:09 a.m.
Hi Sridhar,

I found a forum post with a similar error message, and a developer indicated this was a bug that should be reported:

I found a couple of defects with similar error messages.  Do any of these seem like your case?  If not, you can open a defect by going to My Stuff, clicking on Work Items, and then clicking Submit a Bug.
Exceptions after unloading a component at the same time as accepting from a different component (232826)
Sparsely loading a .project file in an eclipse project breaks the metadata and the project (Inverse metadata IAE) (186226) (see comment 2)
Metadata corrupted during checkin (115002)

permanent link
Sridhar Reddy (122) | answered Oct 10 '12, 7:18 a.m.
 Thanks for your response. Is there a patch available? This is causing a lot of problems. There might be a workaround too, does anybody know? Thx.

Lauren Hayward Schaefer commented Oct 10 '12, 7:40 a.m.

Hi Sridhar,
You may have the most success by commenting in the work item that seems most like yours (or opening a new work item if none seem like your case) and asking if a patch is available.

permanent link
Sridhar Reddy (122) | answered Oct 10 '12, 7:20 a.m.
Defect 186226 says planned for 4.0 M7 - is this something that can be applied on v client. Please note the latest v4 client also failed.

Your answer

Register or to post your answer.