It's all about the answers!

Ask a question

How do I find the Windows 7 value for "fully qualified hostname"?

Kathy Harper (3214) | asked Sep 27 '12, 9:35 p.m.
I am trying to install RTC on my laptop to do demos.  To configure the server, the instructions indicate I need to point my Web browser to the following address:  https://[fully qualified hostname]:9443/jts/setup  What name should I use?  I have tried the System Computer Name, but it doesn't work. I have also tried localhost and mylocalhost.   I am running Windows 7 64 bit.   I would appreciate some help.

Accepted answer

permanent link
Ralph Schoon (63.1k33646) | answered Sep 28 '12, 2:35 a.m.
Hi Kathy,

what I typically do is to put an alias into C:/windows/System32/drivers/etc/hosts for example

# localhost name resolution is handled within DNS itself.       localhost

This allows me to use as a fully qualified host name.
Kathy Harper selected this answer as the correct answer

Kathy Harper commented Sep 28 '12, 12:02 p.m.

Thanks Ralph - just tried it, but still get an error.  Specific message is "The requested resource (/jts/setup) is not available"

6 other answers

permanent link
Clement Liu (1.5k54249) | answered Sep 27 '12, 9:39 p.m.
Was the tomcat server started up OK?

Kathy Harper commented Sep 28 '12, 10:15 a.m.

Thanks for responding.  Tomcat Server did start, but I got a number of errors.  Last message is "Info:Server Startup in 1871 ms". Before that, there are SEVERE messages such as the scratchDir you specified.... is unusable.  I used the Interactive Installation Guide, and it didn't tell me to follow the instructions for " Running in Apache Tomcat as a Windows service (64-bit)"  So I assumed I didn't want to run to do that..

Ralph Schoon commented Sep 28 '12, 10:25 a.m.


please don't install into Program Files on Windows 7. Take c:\somepath\ Otherwise you have to explicitly select run as admin or tomcat might fail to be able to create files and folders.

If you install as a service you have to make sure to provide all the settings in the service configuration and should make paths absolute in the files of the applications.

Kathy Harper commented Sep 28 '12, 12:06 p.m.

Thanks Ralph - perhaps I should uninstall Jazz, RTC (with the IBM Installation Manager), and reinstall into a different folder - IBMJazz, for example.  I would rather not run Apache Tomcat as a Windows service, unless absolutely necessary, as it looks messy changing all the "system" files

permanent link
Michael Afshar (7014) | answered Sep 27 '12, 10:01 p.m.
Hi Kathy,

localhost should work fine in your laptop installation for demos. You use fully qualified hostname if you want to access this server from another computer. Did you install default Derby and Tomcat? Before running the server setup you must start the application server. If you installed Tomcat, you can start it from start > All Programs > IBM Collaborative Lifecycle Management > Start the Jazz Team Server, then wait until everything is deployed and applications are started. Do not close the Tomcat window. You have to keep that session alive as long as you want to be connected to the JTS.

Hope this helps,


Sterling Ferguson-II commented Sep 27 '12, 10:27 p.m.


On the windows 7 machine, can you keep it running as a service?

T M commented Sep 27 '12, 10:45 p.m.

Go to etc\hosts file and put en entry like below:

And, you can use the as your FQH on your laptop.

Kathy Harper commented Sep 28 '12, 12:08 p.m.

Hi - thanks to all.  I did figure out how to add (or uncomment) the localhost entry in the host file, but I am still having problems.  I don't know if my system uses LDAP or not - would this make a difference?.  See above comment to first answer. 

permanent link
Alex Fitzpatrick (5583816) | answered Sep 28 '12, 10:25 a.m.
 On Windows 7 you can find the fully qualified hostname in the System panel of the Control Panel. There will be a section called Computer name, domain, and workgroup settings that list:
  • Computer name
  • Full computer name
  • Computer description
  • Domain

You want the Full computer name

The system Panel can be opened in a number of ways: 
  • My preferred method is to open the start menu then right click on Computer and select Properties. 
  • You can open the control panel and find the System page
  • You can open an explorer window (windows key + e) and type Control Panel\System and Security\System in the address bar.

Kathy Harper commented Sep 28 '12, 12:10 p.m.

Thanks Alex - I actually tried to use the "Full Computer Name" before posting, but it didn't work. I appreciate your response.

permanent link
Anthony Kesterton (7.5k7180136) | answered Sep 28 '12, 1:23 p.m.
Hi Kathy

It sounds like things may have got a bit messy.  You need to do the following

1) set up your etc/hosts file so it can use a fixed fully-qualified domain name as Ralph has suggested.
2) Uninstall RTC and then delete all the files/directories left over in c:\program files(x86)\JazzTeamServer (assuming you used the default settings)  so you really are starting from scratch.
3) Reinstall RTC - use another directory as suggested above - I replace c:\Program Files(x86) with c:\IBM (shorter names are better on Windows :-)
4) Run server.startup to start RTC. 

If you get errors on startup - stop right there and come back here for help.

Assuming you don't have errors - then you can go to the https://[servername]:9443/jts/setup and you will be able to fill in the server name and continue with setup.

LDAP only becomes relevant if you enable LDAP - by default you would be using Tomcat and store users names in Tomcat's user directory.

Hope that helps


Kathy Harper commented Sep 28 '12, 2:11 p.m.

Thanks a bunch!  I was trying to figure out if I had enabled LDAP.  I don't think so (it is one of the questions in the "Interactive Installation Guide")  I will follow your directions, and come back here to advise if it worked, or not.

Kathy Harper commented Sep 28 '12, 4:32 p.m.

Anthony - your solution worked - thanks a bunch

permanent link
Kathy Harper (3214) | answered Sep 28 '12, 1:23 p.m.
Thanks to all for answering my question.  See answers for multiple ways to get a "fully qualififed hostname"As I am still having problems, I will do a new post.

Ralph Schoon commented Sep 28 '12, 4:29 p.m.

Please mark the answer that helped most as accepted.

permanent link
Kathy Harper (3214) | answered Sep 28 '12, 4:40 p.m.

Thanks so much to all that took the time to respond, especially Anthony, who told me how to fix my problem.

I have a few suggestions for people who want to set up a single user demo of RTC on Windows 7, using Derby for the database, and Apache Tomcat for the server  [feel free to correct]:

  1. Before beginning, make sure you have a fully qualified hostname  or create one similar to in the etc\hosts file.  For people not familiar with this,
    1. Open Windows start menu, search for a text editor such as Notepad, right  click, and choose “Run as administrator”
    2. In Notepad, select "File", "Open" and navigate to C:\Windows\System32\drivers\etc
    1. Change file type to  "All Files (*.*)"  "hosts" should be in the list of files
    1. Select "hosts"  [file will open]
    1. View contents and add one line with a name similar to for the same IP address as localhost.  For example:
    2. Save file, making sure there is no # before the file name
    3. [I rebooted, I am not sure this needs to be done]
  2. In IBM Installation Manager, install all files to a directory that does not contain a space.  Therefore change the default directory of C:\Program Files to something short like C:\IBM
  3. After starting the Apache Tomcat server, make sure there are no SEVERE errors in the Apache Tomcat console window before running the setup wizard.
  4. I ran the Express Setup, not the Custom Setup

Anthony Kesterton commented Sep 28 '12, 6:37 p.m.

Hi Kathy

Delighted you are up and running - just some minor corrections to your suggestions.

In spite of the warning, and as long as this is a demonstration system only - you can use an unqualified domain name (for example, localhost will work just fine).  Bear in mind, this is for demonstration only.

The problem with the installation directory is that c:\program files(x86)\ is not a "real" directory in Windows7 - so any proper directory (with or without spaces) is just fine.  To be sure you have a proper directory - create your own one.  I tend to use a short name line c:\ibm to avoid problems in Windows with path lengths for some of the long file paths in RTC.

Express setup is good as it avoid you have to think of values for parameters you may not understand at install time.  Definitely should do a Custom setup for a production system though :-)

Your answer

Register or to post your answer.

Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.