It's all about the answers!

Ask a question

Why don't all plan items show up on my backlog plan?


Troy Dugger (7121015) | asked Sep 18 '12, 1:18 p.m.
I have a product backlog plan that shows 86 work items, but it should show way more and when I click on the link at the top of the plan that says "86 Open", the Work Items view will show 296 work items.  That's correct, I should have 296 items in the backlog plan, but why don't they all show up in the plan?

The plan is for the team that is associated with the root category of the timeline where the backlog is an iteration of.

Thanks,
Troy

Accepted answer


permanent link
Troy Dugger (7121015) | answered Sep 19 '12, 9:58 a.m.
The problem was that the Enhancement type wasn't considered a "plan item".  Once I edited the Process Configuration - Project Configuration > Configuration Data > Planning > Work Item Type Categorization and checked the checkbox for Enhancement, then they showed up in my plan.

Still unknown to me was that some Enhancements were showing up - maybe they were stories to begin with??

Also, Enhancement wasn't considered an Execution Item either, because I didn't have that filter checked in my plan.  My type (that I created based off another team's project area) had some issues, I guess.
Ralph Schoon selected this answer as the correct answer

Comments
Ralph Schoon commented Sep 19 '12, 10:25 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

Troy,

there is, based on the the plan type, a default filter that filters away execution items. Instead of making the enhancement request a plan item, you can set the flag "Always load all execution items" in the (advanced) configuration of the plan.

3 other answers



permanent link
wolfgang steindl (2061011) | answered Sep 19 '12, 2:32 a.m.
Troy,

there are 2 reasons why WI show up on a plan or not :

  1. Each plan uses 2 attributes to decide if a WI is part of the plan or not - "Filed against" and "planned for". You can check within your plan "Plan details" what is set for your plan
  2. Filters are applied (as described in my comment 1 and by Michael)

As you said there is no filter apllied so only reason #1 remains. So pls. check if all your WI belong to the team that owns the plan and if all your WI's are assoziated with the timeline that is reflected within your plan


Comments
Troy Dugger commented Sep 19 '12, 9:54 a.m.

Filed Against was set correctly. They all have a category that is associated with the team the plan is set to. But I figured out the problem. See my answer below. I appreciate you trying to help. Thanks.


permanent link
wolfgang steindl (2061011) | answered Sep 18 '12, 2:04 p.m.
Could it be that you applied a filter on the plan? Above the heading (Summary, ...) there is a text field. Left to the text field you can choose filters. Right to the text field you see how many work items are filtered out.

Comments
Troy Dugger commented Sep 18 '12, 5:43 p.m.

No, it isn't because I have work items that are filtered out. There is no label to the right of the text field.


permanent link
Michael Walker (99214198157) | answered Sep 18 '12, 2:30 p.m.
It sounds like you're filtering out Resolved Work Items in the plan so only the 86 open are displayed.  If you remove that filter it should display all 296.

Comments
Troy Dugger commented Sep 18 '12, 5:44 p.m.

I did have Resolved Work Items filtered out, but none of them are resolved so it was filtering out zero work items. Thanks to both you and Wolfgang for trying to help. I appreciate it.

Your answer


Register or to post your answer.