It's all about the answers!

Ask a question

Floating licenses - required version of license for RRC v4


Anthony Kesterton (7.5k7180136) | asked Sep 07 '12, 7:30 a.m.
JAZZ DEVELOPER
Hi

A customer noticed that they can run RTC v4 floaitng license using a v3 license.  However, they noticed that RRC v4 can't use v3 licenses.

Is this correct?

And if we did install v4 floating licenses for RTC and RRC - would we still be able to run v3.x (ie all v3 versions) off these new licenses?

thanks,
anthony


Accepted answer


permanent link
Daniel Moul (4.9k1318) | answered Sep 07 '12, 1:45 p.m.
FORUM MODERATOR / JAZZ DEVELOPER
JTS introduced the concept of license compatibility levels in 4.0. The 4.0 applications require 4.0 licenses, while the 3.0 applications should work with either 3.0 or 4.0 licenses (that happens because the 4.0 version of the licenses is backward compatible with 3.0).  Thus customers who bought 4.0 licenses can run a mix of 4.0 and 3.0 apps (for example, if they have upgraded RTC (principally the CCM app) to 4.0 but not yet RRC (principally the RM app). The customers with 3.0 licenses can only run 3.0 apps.

>>> they can run RTC v4 floating license using a v3 license
it looks like there could be a RTC license implementation bug

>>> However, they noticed that RRC v4 can't use v3 licenses.
this is the correct behavior
Anthony Kesterton selected this answer as the correct answer

Comments
Guido Schneider commented Sep 10 '12, 4:36 a.m.

BTW: a V.3 floating license server CANNOT serve v.4 licenses. You cannot load them.


Anthony Kesterton commented Sep 10 '12, 3:30 p.m.
JAZZ DEVELOPER

Thanks Daniel/Guido

Your answer


Register or to post your answer.


Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.