It's all about the answers!

Ask a question

Running scm RTC 3.0.1, the zimport is running the scan but stopping when it hits a migrated dataset. Is there a way ti bypass the migrated datasets?


JAMES KENNELLY (3189) | asked Aug 29 '12, 3:14 p.m.
edited Aug 31 '12, 11:36 a.m.
Running scm RTC 3.0.1, the zimport is running the scan but stopping when it hits a migrated dataset. Is there a way ti bypass the migrated datasets?

Here are the error messages.

 BROWSE    /tmp/K351156.11:42:25.69.stderr.ispfudl    Line 00000000 Col 001 080
 Command ===>                                                  Scroll ===> CSR 
********************************* Top of Data **********************************
com.ibm.teamz.fileagent.importz.PDSManagerException: Return code: 4 and reason: [Volume not mounted]. Data set: DMTOOL.ADBEBASE.AADBBASE is skipped
.at com.ibm.teamz.fileagent.importz.PDSManager.listDataSets(PDSManager.java:245)
.at com.ibm.teamz.internal.zimport.cli.subcommand.SimpleMemberLister.listMembers
.at com.ibm.teamz.internal.zimport.cli.subcommand.ZImportCommand.buildProjectMod
.at com.ibm.teamz.internal.zimport.cli.subcommand.ZImportCommand.doRun(ZImportCo
.at com.ibm.teamz.internal.zimport.cli.subcommand.ZImportCommand.run(ZImportComm
.at com.ibm.team.filesystem.cli.core.internal.SubcommandLauncher.run(SubcommandL
.at com.ibm.team.filesystem.cli.core.internal.SubcommandLauncher.doStart(Subcomm
.at com.ibm.team.filesystem.cli.core.internal.SubcommandLauncher.run(SubcommandL
.at com.ibm.team.filesystem.cli.core.internal.Application.start(Application.java
.at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:
.at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(
.at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAp
.at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:368)
.at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
.at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)                
.at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:60
.at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl
.at java.lang.reflect.Method.invoke(Method.java:611)                           
.at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:559)           
.at org.eclipse.equinox.launcher.Main.basicRun(Main.java:514)                  
.at org.eclipse.equinox.launcher.Main.run(Main.java:1311)                      
.at org.eclipse.equinox.launcher.Main.main(Main.java:1287)                     
Problem running 'zimport':                                                     
CRHTC0620E An error occurred while retrieving the data sets under high-level qualifier DMTOOL. 

Comments
John Riendeau commented Aug 30 '12, 10:17 a.m.
JAZZ DEVELOPER

Hi James,

Can you paste the last little bit of the output from zimport? I'd like to see what messages you're getting leading up to the scan stopping.

2 answers



permanent link
John Riendeau (46626) | answered Aug 31 '12, 12:00 p.m.
JAZZ DEVELOPER
Hi James,

Thanks for updating with the stacktrace.  It looks like you're hitting the problem documented in 159640: PDSManager.listDataSets() terminates, rather than skips, when encountering an error, which was fixed in 3.0.1.  Your question states that you're already running 3.0.1, so I'm surprised you'd be seeing this.  I double-checked the line numbers of our 3.0.1 source against those seen in the exception, and they do not match up.  Are you sure you're on 3.0.1 and not an earlier release?  What output do you get if you run 'scm -v'?

 - John

permanent link
JAMES KENNELLY (3189) | answered Aug 31 '12, 12:55 p.m.
Hello John,

Thank you, I had  also opened a forum question on the scm -v output.

I think we need to upgrade the scm s/w level anyway to RTC 4.0 since I am using a RTC 4.0 sandbox and we will be going to RTC 4.0.

SCM - V OUTPUT SHOWS V2.0.1 NOT 3.0.1


edit
JAMES KENNELLY (1) | asked Aug 27, 1:05 p.m.
When using the scm -v command version 2.0.1 shows.

 BROWSE    /tmp/K351156.09:48:12.82.stdout.ispfudl    Line 00000000 Col 001 080
 Command ===>                                                  Scroll ===> CSR 
********************************* Top of Data **********************************
************************************************************************       
*    IBM's internal systems must only be used for conducting IBM's     *       
*       business or for purposes authorized by IBM management.         *       
*       Use is subject to audit at any time by IBM management.         *       
************************************************************************       
com.ibm.team.filesystem.cli.client, version 2.1.0.v20101110_2353               
  Subcommands: load login logout create create/workspace create/baseline create/
                                                                               
com.ibm.teamz.filesystem.cli.client, version 1.1.0.v20101110_2353              
  Subcommands: allocatez listdefz loadz loadzXml create/dataset list/datasetdefi
                                                                               
com.ibm.team.filesystem.cli.tools, version 2.1.0.v20101110_2353                
  Subcommands: tools.verify tools.validate tools.echo.stdin tools.configvalue to
                                                                               
com.ibm.team.filesystem.cli.core, version 2.1.0.v20101110_2353                 
  Subcommands: help version daemon daemon/start daemon/stop                    
                                                                               
com.ibm.teamz.zimport.cli, version 2.1.0.v20101110_2353                        
  Subcommands: zimport                                                         
******************************** Bottom of Data ********************************


Comments
John Riendeau commented Aug 31 '12, 1:14 p.m.
JAZZ DEVELOPER

Okay, that explains it -- those plugin version numbers correspond to the V3.0 release. If you're planning to move to V4 anyway, this won't be an issue for you there.

Your answer


Register or to post your answer.