It's all about the answers!

Ask a question

New Setup CLM4.0-WAS8.0-DB2 9.7 : WAS not start up


Kazuo Fujita (147) | asked Aug 24 '12, 12:14 a.m.
Installation is on Widows7 WAS 8.0 with CLM4.0 and DB2 9.7.
At first I created profile of WAS. Post id is 9080. First step of WAS success and WAS started.
When WAS setup, I ran the clm_was_config.py. I then restart the WAS.
WAS didn't restart.
clm_was_config log show

startServer.log show




Comments
Ralph Schoon commented Aug 24 '12, 2:31 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

I can't see any information that would help understanding the details. RSSOwl seems to show an embedded picture but it does not display there or in my browser.


Kazuo Fujita commented Aug 24 '12, 4:18 a.m. | edited Aug 24 '12, 4:27 a.m.

Sorry. Reshow below. add line number and [ ] clm_was_config.py log last 11
[1. Disabled Java2 Security] [2. Enabled Application Security] [3. Enabled Administrative Security] [4. Enabled Unprotected URI] [5. Setting configuration for Application Server server1] [6. Set initial and max heap size to 4096] [7. Set JVM args -Xmx4g -Xms4g -Xmn512m -Xgcpolicy:gencon -Xcompressedrefs -Xgc:preferredHeapBase=0x100000000] [8. Created JAZZ_HOME JVM custom property] [9. Created java.awt.headless JVM custom property] [10. Created org.eclipse.emf.ecore.plugin.EcorePlugin.doNotLoadResourcesPlugin JVM custom property] [11. Created log4j.configuration JVM custom property]

startServer.log last 6

[1. WindowsServic 3 inputRec == Service failed to start. startServer return code = -1] [2. WindowsServic 1 retCode from childProcess.waitFor() is -1] [3. WindowsServic 3 -- interrupt the thread that is collecting stdout] [4. WindowsServic 3 exitCode = -1] [5. WindowsServic 3 readAndDisplayServiceLogFile(), caught InterruptedException] [6. AdminTool A ADMU7704E]

3 answers



permanent link
Ralph Schoon (56.3k23642) | answered Aug 24 '12, 4:30 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
Can you look into https://jazz.net/library/article/662 ? There is a troubleshooting document with issues we saw when creating that workshop.

My best guess would be that the service did not stop in the first place. You can check that by looking into the processes. We mention how to detect that in the troubleshooting document. I usually look at the service state if things seem to be weird.

Comments
Kazuo Fujita commented Aug 24 '12, 5:46 a.m.

Thank you Ralph. I downloaded and I saw M2011_Upgrade_AppendixA_Troubleshooting. I think it is a great document. I read Unable to Start a WAS Profile. This phrase was the most appropriate but also read the other. I thought so. I saw Task Manager but both java.exe and WASService didn't run. My problem was not solved. But are grateful for your kindness.


permanent link
Ralph Schoon (56.3k23642) | answered Aug 24 '12, 6:18 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
Can you have a look at the WAS logs (in the profile folder) maybe there is something else. Another thought, how much memory do you have? The modified WAS profile will use a lot more than the old one. Just some guesses.
Try to start the service or the profile manually, check the system event logs.

Without any data it is hard to help.

permanent link
Kazuo Fujita (147) | answered Aug 27 '12, 5:14 a.m.
Thank you for your comment. I already show startServer.log above.  I saw other logs and there were 2 log(SystemOut.log,ffdc>server1_exception.log). SystemOut.log : ADMN1216I located close to the time of occurrence.  server1_exception.log : java.lang.NullPointerException com.ibm.ejs.j2c.RALifeCycleManagerImpl.stop 336 
My RAm is 4.0GB.
System event is logname:         Application
source:           Application Error
Date:            2012/08/24 17:14:09
Event ID:       1000
Task Category:      (100)
Level:           Error
Keyword:         Classic
User:          N/A
Computer:       ***********
Description:
Application: java.exe,Version: 6.0.0.0,Time Stamp: 0x4e1e9c64
Module: j9vm26.dll,Version: 2.6.1.22447,Time Stamp: 0x4e32e402
Exception Code: 0xc0000005
Offset: 0x000000000000d903
Process: 0x1734
Start Time: 0x01cd81d06e3290a3
Application Path: C:\Program Files (x86)\IBM\WebSphere\AppServer\java\bin\java.exe
Module Path: C:\Program Files (x86)\IBM\WebSphere\AppServer\java\jre\bin\compressedrefs\j9vm26.dll
Report ID: adcc3554-edc3-11e1-8b6a-cc52afe2029a
Event XML:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="Application Error" />
    <EventID Qualifiers="0">1000</EventID>
    <Level>2</Level>
    <Task>100</Task>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2012-08-24T08:14:09.000000000Z" />
    <EventRecordID>11297</EventRecordID>
    <Channel>Application</Channel>
    <Computer></Computer>
    <Security />
  </System>
  <EventData>
    <Data>java.exe</Data>
    <Data>6.0.0.0</Data>
    <Data>4e1e9c64</Data>
    <Data>j9vm26.dll</Data>
    <Data>2.6.1.22447</Data>
    <Data>4e32e402</Data>
    <Data>c0000005</Data>
    <Data>000000000000d903</Data>
    <Data>1734</Data>
    <Data>01cd81d06e3290a3</Data>
    <Data>C:\Program Files (x86)\IBM\WebSphere\AppServer\java\bin\java.exe</Data>
    <Data>C:\Program Files (x86)\IBM\WebSphere\AppServer\java\jre\bin\compressedrefs\j9vm26.dll</Data>
    <Data>adcc3554-edc3-11e1-8b6a-cc52afe2029a</Data>
  </EventData>
</Event>

Your answer


Register or to post your answer.