It's all about the answers!

Ask a question

Read-Only Pre-condition does not show up to be configurable

Jorgefelix Siverio (7611414) | asked Jul 23 '12, 4:55 p.m.
Hello Jazz Community,

Our team has ran into a bit of a wall here. We are in the Operation Behavior section and we wanted to use the precondition, Read-Only Attributes for Type and State. When we add this to the list of preconditions nothing shows up in the window to allow us to configure them.

We read through these instructions but do not see the configuration box that should appear on the lower right hand corner of the screen

Any insight on why this feature is not working as expected would be very helpful.

Thank you!

Millard Ellingsworth commented Jul 23 '12, 7:15 p.m.

The upper portion of the Operational Behaviors section is a grid of operations and roles. You need to select a cell in that table to indicate the role and operation for which you want to configure the precondition. If nothing is configured for that role/operation, the cell is empty, otherwise it has an icon in it. The article you listed doesn't really talk about that part, so just making sure you realize how the page works in general.

If you choose the Save Work Item (server) operation and the Everyone role (which may already have an icon in it), then make sure the "Preconditions and follow-up actions are configured for this operation" check box is checked, then click Add... to choose Read-Only Attributes for Type and State (or select it in the Preconditions list), the area to the right should display configuration options. I have tried it with multiple users (some who don't have permission to save the changes) and it always works fine. If you still can't make it work, please describe your steps in more detail so I can try to reproduce it.

2 answers

permanent link
Jorgefelix Siverio (7611414) | answered Jul 24 '12, 8:22 a.m.

The "configuration options" you refer to in your third to last sentence is what does not appear. Please find the steps we take below.

1. Open Eclipse client v3.0.1.3 (running CLM 2012)
2. Open Project Area
3. Select Process Configuration
4. Expand Team Configuration
5. Select Operation Behavior
6. Select icon, in the top matrix, for Save Work Item (server) and Everyone.
7. Preconditions and follow-up actions are configured for this operation check box is already marked
8. In the preconditions section click Add and select Read-only attributes for Type and State
9. Select Read only attributes for Type and State

No configuration options appear. Note: configuration options do appear for "required attributes for type and state".
All roles and permissions and the RTC, RQM, RRC licenses are assigned to the test account.

Thanks for the help.

Millard Ellingsworth commented Jul 24 '12, 1:44 p.m.

You are correct, this does not work with the older client. Since this is a new feature for CLM 2012 I (incorrectly) assumed you were running a 4.0 client. I will file a defect for this, add you as a subscriber and put the link in a comment here shortly.

permanent link
Millard Ellingsworth (2.5k12431) | answered Jul 25 '12, 12:13 p.m.
Upon digging into this some more, I don't think this will be fixed. Our N-1 client support covers any developer activities but this is considered an administrative activity for which a current version client is required.

Your answer

Register or to post your answer.