It's all about the answers!

Ask a question

LDAP error when creating user


Sterling Ferguson-II (1.6k7244253) | asked Jul 16 '12, 5:04 p.m.
edited Jul 16 '12, 5:54 p.m.
 All,

CLM/WAS/DB2

I am running jts_setup. I am in the JazzAdmins and I have successfully logged in as jdoe to start the setup.
The LDAP test was successful, now I need to allocate licenses to jdoe. I get the following error:

The new user could not be created. See the details for more information. For additional information, open the help system and search for CRJAZ1551E.ID CRJAZ1551E

We searched and found this, but our user is in the JazzAdmins group and we can't sync with JTS, because we are still in setup mode.

https://jazz.net/forum/questions/71313/ldap-there-was-an-error-attempting-to-create-the-new-user


Just to run a test. We logged in to /jts/admin successfully as jdoe. Import Users is available, and it lists every LDAP user that is not in JazzAdmins or JazzUsers.

Comments
Karl Weinert commented Jul 19 '12, 10:40 a.m.
JAZZ DEVELOPER

I found this technote that may be related. https://www-304.ibm.com/support/docview.wss?uid=swg21424134

If that does not help it might be good time to open a PMR so we can collect logs.

2 answers



permanent link
Karl Weinert (2.0k42536) | answered Jul 17 '12, 7:51 a.m.
JAZZ DEVELOPER
Check the case of the jdoe in the LDAP server
i.e. Jdoe is as opposed to jdoe

Does jdoe show up correctly in user administration from /jts/admin?
Does jdoe show up correctly in the top right corner of the browser window when logged into /jts/admin?
Sometimes issues with LDAP will cause the user to show up as ADMIN

You can try to add the license from /jts/admin then go back to setup and skip that step.

And I am curious what you mean when you say "Import Users is available, and it lists every LDAP user that is not in JazzAdmins or JazzUsers" 
Could you explain that a bit more?

Comments
Sterling Ferguson-II commented Jul 18 '12, 6:10 p.m.

Hello,

Thanks for your response.

  1. jdoe does not show up correctly. It's listed as ADMIN/ADMIN
  2. It will not move forward, because the user cannot be created.
  3. I went into jts/admin and took a look around. I saw that Import Users was available, and I clicked on it. It lists every user we have in LDAP except the ones we put in JazzAdmins and JazzUsers.

permanent link
Frank Ning (50023111131) | answered Jan 06 '13, 4:11 a.m.
Hello,

Was this solved? And how?

I had the similar issue (same error message). I used Tivoli Directory Server 6.3 with DB2 and WAS. This is for my own testing box and thus I ignored email parts. It turned out, for my case, that the "User Property Name Mapping" was not right. After that was fixed, the "Next" allowed me to continue to next step. To be safe, I imported the users (admin, data collector, and reporter IDs) from jts/admin before I clicked "Next".

Overall, setting LDAP with WAS and then Jazz is kind of tricky to CLM administrator, especially for non LDAP SME dealing with non-"standard" or non-"conventional" LDAP user settings. I found "Softerra LDAP browser" is pretty helpful and using MS AD is much more easier than using Tivoli DS from points of view of both user setup on LDAP site and configure JTS with LDAP.

It was fun to make Jazz work with both TDS and MS AD.

Good luck and share your experience if possible.

Thanks and regards
Frank



Comments
Frank Ning commented Jan 06 '13, 10:51 p.m.

Sorry, forgot to mention one part I used to proceed the set up steps:

1) When the warning showed up on LDAP setup step, login jts/admin as the Jazz administrator ID (not intentionally "ADMIN"). Import the users from LDAP. You would notice that the jts/admin login ID is shown as "ADMIN". Log out and login with your desired admin ID to confirm that jts/admin now shows that ID.
2) logout your LDAP setup page, then ,login again with the jazz administrator ID. Now the "Next" can really allow you to proceed.

This is what happened to me with CLM 4.0.1 and Tivoli Directory Server.

Your answer


Register or to post your answer.