It's all about the answers!

Ask a question

scm create workspace fails

Liora Milbaum (513282116) | asked Jun 20 '12, 10:37 a.m.
edited Jun 20 '12, 11:07 a.m. by Tim Mok (6.6k38)

I am trying to create a workspace with the following command line:
scm create workspace -r https:rtcserver:9443/ccm -s steamName workspaceName

I recieve the following error:-
Problem running 'create workspace':
Could not loging to https:rtcserver:9443/ccm as "userName". Already logged in as "userName".
Run "scm logout" and retry.

I have tried the same command without the stream option and worked with no problem. 

I am working with RTC server, RTC CLI 3.0.2. My repository intialy created in RTC 2.0 and was migrated to recently.

Please assist,

Evan Hughes commented Jun 20 '12, 11:46 p.m.

Have you tried logging out?

Accepted answer

permanent link
Arne Bister (2.6k12832) | answered Jun 20 '12, 11:26 a.m.
Hi Liora,

a similar case with answer was reported in the forum in this entry.
Basically it comes down to using your user id in UPPER CASE when you first log in, for example
>lscm login -r https://myserver:9443/ccm -u ABISTER -p ...
rather than "-u abister"

Explanation see linked entry.
Does this work?

- Arne
Liora Milbaum selected this answer as the correct answer

2 other answers

permanent link
Karl Weinert (2.0k52736) | answered Jun 20 '12, 11:15 a.m.
Are both userName values the same in the error?
Are they your account?
Two different users cannot log into ccm from the same OS account at the same time.
Even using the scm logout does not work consistently.
I believe it is controlled by something in  the jazz-scm directory.

permanent link
Liora Milbaum (513282116) | answered Jun 23 '12, 12:06 p.m.
Thanks Arne and Karl, your answers worked for me and solved the problem.


Arne Bister commented Jun 23 '12, 12:29 p.m.

May I ask you to please mark the appropriate answer(s) as accepted? This will help with queries against questions with non-accepted answers and help Karl and I with our forum reputation :-) Thx,


Liora Milbaum commented Jun 23 '12, 12:39 p.m.

Done. I am not familiar yet with the new forum. Getting there as you can see :-)

Your answer

Register or to post your answer.